• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Sawtooth G4 screen stays black

My Sawtooth G4 400MHz AGP won't bootup anymore.

Only yesterday, I started the machine and it started as before. Today, in (likely) same setup, it does not startup anymore.
The power supply fan starts spinning. But no chime, no video.

Meanwhile I removed the SCSI card, the SATA card, the ethernet card, the ATI AGP graphics card, all of the SDRAM, the PRAM battery, reseated the CPU, unplugged all ATA drives and pressed the reset button on the mainboard several times. (while plugged, while unplugged, while "running", with battery, without battery). Attached a firewire drive, but it did not help as well.

The hard drive does not start spinning, when it is connected to the ATA bus. When I unplug it from ATA, but have power connected to the HDD, the drive starts spinning. Same applies for the DVD-drive: When connected to the ATA bus, it won't react to pushing the open tray button. When only connected to power, the tray opens upon pressing the button

Could it be, that the ATA controller is somewhat locked/held in reset?

Does anyone have a hint or a link?

Thanks in advance!

BTW: I bought the machine earlier this year and bought a G4 Sonnet Encore 1.8GHz upgrade for it soon afterwards. With this beast installed, the machine ran MacOSX 10.5 fine and stable. But when I switched to MacOS9.2.2 or MacOSX 10.4, soon, the machine froze. Therefore, I removed the G4 upgrade and had it running stable with the original CPU.
Last edited:
I don't know, what's going on, but after a break, I tried with the G4 upgrade in it and then I heard a chime.

Plugged in one memory module and the Radeon, but still no video. But I could hear the Platinum system sounds. Luckily I had installed VNC in the MacOS9 as startup item and was able to connect via Remote Desktop: MacOS9 was there and alive.

Reselecting the startup drive to MacOSX10.4 allowed that one to boot, showed video, though the video was flickering a little (strange thing on HDMI - via Remote Desktop no flickering).
Changing resolutions and reverting them back to full HD let video be stable as well.

After a few minutes, the machine froze in 10.4.12. (the problem I had previously with the G4 Encore upgrade, when ran outside of 10.5.x - in 10.5.x, it was stable).
Now rebooted into 10.5.x and still it seems stable.

I am still wondering, what was/is the reason for
- the instability under 10.4.x or MacOS9, when running with the G4 Encore upgrade
- the near-death experience, where the ATA bus seemed to be held in reset with the original 400MHz G4-CPU

Gonna switch back to the original CPU to see, if that comes back again or if it refuses wo work with that CPU.

to be continued...
With the original CPU, the machine does not chime and does not boot.
Back with the Sonnet Encore, the machine starts, but freezes in any OS aside from 10.5.x (Sorbet)

The RAM is back in to its max of 2GB. The SATA card is back in and the Sonnet Gigabit ethernet card is meanwhile back in the machine as well.

Until now, the PRAM battery and the SCSI card are still outside of the machine, but it seems, the error is related to the original CPU.

This leaves me with the questions:
- whats up with the original CPU, why does it prevent the machine from chiming?
- why does the machine freeze with the Encore upgrade in any OS aside from Sorbet Leopard?


Well-known member
Question: Does the Sonnet require open firmware tweaks to be installed prior to installation, and removed prior to putting the stock cpu back in, like my MDD G4 does? I don’t know whether or not this would cause any of the problems you are seeing with OSX Tiger, but I offer it as a suggestion.


Well-known member
The CUDA on these can crash easily - the chip is sensitive. You shouldn't try to reset it while its running. You don't want to keep pressing the reset button, you need to press the button once and leave it alone - with the machine powered off. Press the button a single time, wait 10 seconds, power it back on.

I am not sure how protected these are from incorrect reset procedures such as trying to do that while it was powered on, I wouldn't be surprised if the CUDA is toasted.

But... in case I am wrong...

Are any pins on the original CPU bent?

Have you tried with different RAM?


Well-known member
I have tracked weird problems like this to failing power supplies. In each case re-capping the PS fixed it. Can you swap parts with a working machine to narrow things down?
Thanks for your hints!

No open firmware tweaks necessary. At least I did not recognize any indication from the manual of the Encore G4 upgrade.

I do not see any bent pins.

Thanks for the hint regarding CUDA and how to use this reset button. I will be more cautious in the future. If I did harm to the CUDA device, can the new symptoms after uncautiously pressing the button (not working with the original CPU, working stable with the Encore under Sorbet) match a possible harm of this CUDA device?

Will try the RAM modules, that once came with the machine. Thanks for this hint.

The aging capacitors are a mystery to me. I have no real experience with these, so I can not judge this. Neither can I compare with other examples, as this is the only Sawtooth, that I have. But from the age of the machine and with it of the power supply, if the caps in the PS are suspect to suffer from aging effects, it could well be, that this is the source of an unstable machine, when run under anything else than Sorbet (and probably Sorbet has a better power management or causes a different load on the power supply and the machine therefore suffers not/less from the instability)

Are there chances to get an exchange power supply? A new one of the same type or a compatible one? Where from in mainland Europe? Or should I try to get another used Sawtooth and switch the power supply? Or is poking with ATX power supplies a promising way (for a non-soldering guy)?

BTW: The instability means freezing, whereas the mouse pointer can be moved, but the machine does not react to mouse clicks/keyboard inputs and meters like menu meters are no longer updated/redrawn. So only a partial lock/freeze/crash and not a complete one with a bluescreen/restart of the machine.
After replacing the 4 512 MB RAM modules by a different, single 512 MB DIMM let the machine run stable under Sorbet.
Changing to MacOS9 had the machine stable initially as well. But right when I started Classilla, the machine froze.
Back to Sorbet, I was able to run XBench and WinXP in VirtualPC for a while without problems, so I switched to 10.4.12.
10.12 seemed stable as well, but right in the moment, when I started Snood, the machine froze.
Back to Sorbet, I started the same Snood installation and played it for a while with no freeze.

Machine is still running under Sorbet.

Next step is to put back the 4 512 MB DIMM modules, as reducing to one single, different module did not change the situation...
The full 2 GB memory are back in.

And I could not withstand another try with the original CPU: Same result as since yesterday: With the old CPU, there is no chime, so I have to stick with the Encore upgrade and with it Sorbet (and no 10.4, nor 9.2, nor 8.6).

I suspect the power supply to having become weak.

I'll try to find either another Sawtooth for comparison or reproduction, or a separate power supply replacement, either original or ATX mod.

Enough for today...