• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Resurrecting a Macintosh IIx


Well-known member
Good afternoon folks. I recently picked up a dead IIx. It wouldn't even bumpstart when I first saw it, but I'm not sure why as it sort of did once I got it home (it chimed and showed the happy mac before doing a weird restart with no chime - after a couple of times it froze). Note that it does not restart if there is no disks connected. Additionally, the video is pale and washed out, except once in a while when it is normal.

It is now a couple of weeks later and I've spent the weekend researching and repairing. I've fixed 6 broken traces and checked lots more in the power circuit. I've re-capped most of the motherboard (I don't have a replacement for the yellow 10uF or the axial 220uF (might have the value wrong - it almost faces the board!). The power on circuit now works from ADB and the button on the back.

Machine is a late variant (March 1990) and has a soldered CPU and factory battery holders (no funny little board or capacitor). 8mb of RAM, Radius 24 Pro XK, ethernet and a 540mb disk. At some point someone had a Radius Rocket in it, but sadly that is gone.

Does anyone have any suggestions for what might be wrong? I don't know the machine's history so it could even have the wrong RAM fitted for all I know.

Issue summary:

1. Restarts silently without an error while showing the Happy Mac.

2. Video is washed out.

Youtube video for reference :





Well-known member
Interestingly, it doesn't reset itself when there is no startup disk at all (and the question mark is flashing). Does this mean it fails when RAM gets busy as the OS starts to load in? (I assume that the flashing question / disk runs entirely from ROM). Because of this, I feel the issue is less likely to be the power circuit, unless it is having a brownout when something happens that drags the voltage down? Perhapa a trace has continuity... but is too thin to carry what is required of it?

At least it has always done this so it isn't my repair :)

I tried some different RAM in it just in case - I knew it was probably incompatible because it was high density + low chip count, but if nothing else I wanted to check that the symptoms are different with the wrong RAM. Yup - it just straight up chimes of death with 4 16MB simms in bank A... I didn't really expect any different.

I saw something about a diagnostic mode that you can access through the modem (I think) port - has anyone used that before?

Please forgive my soldering! I checked for shorts, and it is enamelled wire.




Well-known member
So more investigating - I swapped in a working floppy drive and the machine will boot from a floppy!

This means it only seems to crash when trying to boot from scsi...

Plus the washed out video.

Photo of it booted in System 6 with a drive from a 6100 :)




Well-known member
I am attempting a similar repair on my Macintosh II right now (although you are having much better luck than me with this). I have a few ideas that you might want to try testing on your machine. :)

Since you are only able to boot with a floppy disk, I would recommend trying to see if there is continuity in all of the traces for the SCSI controller chip. If not, repair the traces and try using SCSI. Otherwise, I would try to remove the SCSI chip and clean underneath it thoroughly with isopropyl alcohol before reattaching it. This chip is close to a capacitor and can become glitchy if it has corrosion on its pins. Replacement chips are still available online for a low price too.

The washed-out video may be the result of a low contrast setting in your monitor settings. It looks to me like all of the proper signals are being generated by the video circuitry, so I don't think that the Macintosh IIx is to blame for this issue. Maybe the issue could also lie with the dongle that you are using to connect to a VGA screen?

In addition, it looks like there is a ton of flux on the PCB leftover from your soldering rework. If you have not cleaned it off already, I would recommend doing so now with some isopropyl alcohol, as flux can have corrosive/conductive properties, and is not really supposed to stay on a circuit for very long.



Well-known member

Thanks for your response and good luck with the II. I started by repairing all trace damage I could see and checking the continuity of what looked suspect, then beeped out each connection on the power circuit that I'm sure you have seen, scribbling out each link one at a time. Sadly the component labels don't exactly match my machine - e.g. D4 and D6 are reversed, and I C6 isn't C6 on my board... never found what it was!

I also renewed the solder on some of the suspect chips - the SCSI chip, the UB1, UB2, UA15 and UB15. I need to replace the 7905 as that is crusty and might be causing issues with the power to the HD. I have some I think...

More luck last night. I got it booting from the external SCSI. I currently suspect the SCSI cable or traces to the internal port... or the HD being weird.

Yes, the flux is mostly cleaned - but it is also "no clean" flux so I haven't done it 100% yet until I know I'm done. Trying not to waste IPA as it is expensive atm.

Planning to re-soldermask where I removed corrosion too.

I need to double check the PRAM circuit as I think it isn't remembering video settings. Also get an older version of the video drivers now that I have it booting from something bigger than a floppy.

Still not worked out the graphics - no other card to try, or Nubus computer to try this one in. The VGA adapter works fine on everything from a 6100 to a 9600. Don't have any other 68k macs here with video out to try.



Well-known member
Woo, worked out the graphics issue - the monitor didn't like been overclocked that hard from the IIx. It is usually ok at 75hz, but for some reason it wasn't here.

At the moment I've found that it runs at 72hz in 800x600... still technically too fast, but the screen copes.

Just disk and possibly pram issues now! So close! From dead to photoshop in ~3 weeks!


Last edited by a moderator: