• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Requesting help for a Mystic black screen issue

Hey y'all,
Before I go on, I just wanted to say that what y'all are doing here is fantastic and I'm so glad to have found this community. Thank you for keeping these awesome machines alive and vibrant!

I was wondering if I might be able to ask for a bit of help with a Color Classic Mystic issue I'm running into. I performed the 640x480 modification today, following the standard Option 1 approach here:

I checked my work, made sure that I hadn't cut any lines that weren't supposed to be cut and hadn't accidentally bridged any pins, then plugged the analog board back into the machine. I reattached all necessary cables (including the green ground wire), then took to undoing the 512x384 mod that had been made on the logic board:

1. I removed the 4.7 kOhm resistor at R109
2. I made a solder bridge at R116
3. There was no resistor at R110 (and hadn't looked like one had been removed by the machine's previous owner), so I left it alone.

Upon my first post-mod powerup, the machine soft-powered on and chimed successfully, but the screen remained black. I realized that I'd made a rookie mistake: I'd neglected to plug the anode cap in the whole way, as I heard a few sparking noises. I removed power immediately, discharged the cap via the screwdriver-and-alligator clip method (for what it was worth) and ensured that all analog board connectors were properly connected.

However, despite these changes, the screen remains black and I can feel no static on the front of the screen, so I'm working to figure out why. There are a few positive signs:

1. The logic board reliably soft-powers on and chimes, and no Sad Mac songs play, so I don't think that I've fried the motherboard
2. When I switch the machine on, I hear the customary high-pitched charge sound
3. When the machine soft-powers on, I hear another customary high-pitched charge sound from the CRT and the big coil begins to make some sounds

However, despite these signs, the tube at the neck of the screen does not glow orange, so I was wondering if y'all might have any ideas of where I might look for trouble here, as I fear that I'm stumped at the moment.

Thanks so much for the consideration!


Active member
Did you reinstall the VRAM? If yes, can you post some photos of the analog board mods? Additional sets of eyes on your work may help spot a problem.
I reinstalled the VRAM and, you bet, I’ve attached two pictures, one with the sense line mod and another with the power modification as well.


  • IMG_0846.jpeg
    2.1 MB · Views: 17
  • IMG_0845.jpeg
    2.1 MB · Views: 15


Well-known member
Hard to tell but I'd look at where you cut the bridge a bit more, ideally use a scalpel/blade to space out the cut trace some more. Also clean the LC575 and CC edge connectors well with electronic cleaning solvent as this connection can also be quite sensitive. Try also resetting PRAM.
Hey y'all,
I picked up some board cleaning supplies and DeoxIT today alongside a few more tools. I started out by applying some PCB cleaner to the board, particularly around the points where the connector attaches to the board, which definitely removed some gunk.

I then took to spacing out the trace cut on the bridge a bit more. I started with an X-Acto knife but ultimately moved to the Dremel to see if I could get a bit more isolation going (famous last words). The Dremel was quite effective at isolating Pin 25 but also ended up severing the connection between pin 18 and 32 (I think it's a ground plane), so I soldered in a bodge wire; these results can be seen in picture 1. All continuity tests I stuck some electrical tape between the two jumper wires as well as above and below, which is in picture 2.

Next up, I did a bit more cleanup on the power jumper and stuck some electrical tape around those points as well, in pictures 3 and 4. From there, I applied DeoxIT to the analog board socket and plugged/unplugged the board a number of times to work it in. I repeated this against the 575 logic board socket as well, and, after giving the machine some time to dry, I hooked everything back up and tried to power it on.

When I flipped the switch on, I heard the customary high-pitched power charging sound, and when I soft-powered on, I heard another high-pitched power charging sound alongside the startup chime. About 10-15 seconds later, I heard what sounded a tiny bit of static-like noise, the sort of sound you'll hear when a CRT is coming online. The coil between the neck and the glass screen continued to make a bit of a humming sound.

Unfortunately, the screen remained black at this point, with no static electricity on the front of the screen, so I reset the PRAM several times through 5 separate startup cycles. Alas, the screen still remained black, but, on the upside, it seems like the logic board remains OK.

I noticed, about five minutes into the machine being on, that a black box right by the degauss cable became rather warm; I've highlighted this object in picture 5. Picture 6 is of the neck tube on the CRT whereas pictures 7 and 8 are general views of the connections on the analog board.

I was wondering if y'all might be able to do me a big favor and look over my work again; I get the feeling that I may have fried the analog board somehow, or may have fried the tube when I soft-powered on without the anode cap being well-connected.

I might end up doing some eBay spelunking for parts machines tonight to see if I might purchase a sacrificial unit or two to continue the job.

One way or another, thanks so much for all of your help so far. I've done a lot of work like this in isolation so it's been wonderful to speak to some folks who've worked on these machines before.


  • IMG_0853.jpeg
    1.6 MB · Views: 11
  • IMG_0855.jpeg
    1.5 MB · Views: 10
  • IMG_0857.jpeg
    1.5 MB · Views: 9
  • IMG_0858.jpeg
    1.3 MB · Views: 10
  • IMG_0859.jpeg
    1.3 MB · Views: 11
  • IMG_0860.jpeg
    959.1 KB · Views: 11
  • IMG_0862.jpeg
    1.8 MB · Views: 11
  • IMG_0863.jpeg
    1.8 MB · Views: 14
I’ve done some more digging over the past few and I ended up picking up another CC which has its analog board and motherboard fully recapped.

I performed the 640x480 mod again on this one, cutting far more carefully, applying UV solder mask and making as precise solder joints as I could. Much to my delight, the screen came back to life when I used it with the original CC motherboard.

However, when I plug in the Mystic motherboard from the other machine, the recapped/analog modded machine chimes and boots successfully but the screen still does not light up.

I tried resetting the PRAM and reflowing the solder joints that undid the 512x384 mod the board arrived with, but, alas, no change.

I’m going to fully recap the Mystic board next weekend, but until then, I was wondering if y’all have heard of something like this happening before.

I’ve attached pictures of the new mod as well as the reflowed solder joints on the LC575 (please forgive the pad that came up on R110). I’ve also included a picture of the new screen geometry post-mod with the original CC motherboard.

Interestingly, the original CC motherboard still reports the modded screen’s resolution at 512x384. AFAIK, I think this may be due to it not being able to put out a VGA signal without further modification (honestly, though, I was surprised that it worked at all).

One way or another, I really appreciate y’all looking at my post and all the best!


  • IMG_0024.jpeg
    961.3 KB · Views: 5
  • IMG_0001.jpeg
    1.7 MB · Views: 5
  • IMG_0002.jpeg
    1.3 MB · Views: 5
  • IMG_0003.jpeg
    1.2 MB · Views: 8
  • IMG_0004.jpeg
    1.5 MB · Views: 11
Oh! One other note, the mod pics are missing the pin 20 isolation that I ended up performing last as I realized that the new board did not have J78.