• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

quadra 660 recap

imactheknife

Well-known member
I recapped both a 575 and a 660av. 575 no issues. 660 worked, but now nothing. Checking over all joints etc. Is it possible to lose grounding? it it dead and not Sure why?
 

imactheknife

Well-known member
it doesn't chime, light comes on etc. get almost like a humm in the speaker, like it is grounding or something. Still dead. hope it isn't gone..was a nice system
 

imactheknife

Well-known member
Ok, well i was checking over the board tonight and noticed something loose. Little 223 chip had come off and had electrolyte goo under it. So cleaned up the chip and another one came off. Is this possibly why board is non functional?
 

Attachments

  • 62DBF13D-B227-49C6-8201-2A5392D9AD2E.jpeg
    62DBF13D-B227-49C6-8201-2A5392D9AD2E.jpeg
    2 MB · Views: 18
  • 4523F1D9-AE10-47AA-8C69-DA9837F4C1FD.jpeg
    4523F1D9-AE10-47AA-8C69-DA9837F4C1FD.jpeg
    1.9 MB · Views: 13

imactheknife

Well-known member
Can you order these? Or do i have to scrounge from a parts board?
 

Attachments

  • AE9C290F-4CCE-4D14-96DC-81E9CDD3BD0B.png
    AE9C290F-4CCE-4D14-96DC-81E9CDD3BD0B.png
    4.1 MB · Views: 13

imactheknife

Well-known member
Well, all is well in this project. Cleaned up those two 223’s, hot aired them back on. Gave the whole board a dip in the vinegar / warm water tank for an hour with some toothbrush scrubs. Gave the board a distilled rinse, and finished off with a week dry out. She works, sound works (didnt before) unless i had headphones in.
 
Top