• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Macintosh Portable not booting. Black screen and no chime.

nnn

Member
I have recently got a Macintosh portable (M5120) that did not come with a hard drive or a correct power adaptor (It did come with a original battery but it outputs 1.5V so it appears to be dead).

Previous owner told me that he used one of his existing plug to power it up and it would sometime boot up to a disk with a question mark and other times, it would not boot. Unfortunately, I found out that he used a plug that outputs 24V and 1.2A.

I recapping all capacitors (some caps showed sign of minor leakage but I didn’t notice any damage to traces) then used bench power supply to power the computer from the battery compartment pins (6V with max of 1 amp). When I turned on the computer, I get a black screen and no chime (floppy drive is disconnected). When I turn on the computer with the floppy drive connected then it would make a single click sound (I believe sound is coming from the speaker) and black screen. Symptom is the same whether I connect the 9V battery or not. When the computer is powered on, the power supply shows 6V and 0.17A.

I also replaced a mosfet (Q1) with another IRF9Z30 as I thought it was shorted but replacing it had no effect.

I read number of mac portable repair posts but nothing with the symptom that I am seeing. Could this be problem with the SWIM chip or the Hybrid board?

Just thought to ask the forum to see whether there is any hope in getting this computer up and running.
 

moldy

Well-known member
Can you measure the voltage on the +5V line? I have one dead M5120 where Hybrid is shot and the 5V regulator just doesn't work.

If +5V is fine, could you check what are the levels on SYS_RST and SYS_PWR?

The official schematic for Portable is available so that should facilitate the troubleshooting.
 

nnn

Member
Thank you moldy for your reply.
I checked the voltage in C16 capacitor + side and it shows 5V. Also checked bottom 11th and 18th pins on the hybrid board per attached picture (pins I checked are circled) and they both showed 5V. This was done based on photo by Mc128k in one of his old post (https://68kmla.org/bb/index.php?threads/macintosh-portable-power-regulation.6648/).
Let me know if 5V need to be checked elsewhere.

How would I check the levels on SYS_RST and SYS_PWR? Would that be the J21-9 pin for SYS_RST and the J21-16 pin for SYS_PWR (as I found a diagram by techknight on the same post)?
If so, does pins number start from 1 at the top (on J21)?
e.g would top pins be 1-25 on top and 26-50 at the bottom?
Sorry about these silly questions. As you can see I am a novice.
 

Attachments

  • Hybrid.jpg
    Hybrid.jpg
    1 MB · Views: 31

nnn

Member
Thank you wymtb. I missed that post and that looked really promising.
However, I have followed the instruction provided by Siliconinsider but no change in the symptom. Black screen and no chime.
 

moldy

Well-known member
@nnn

C16 is connected to the always on +5V rail so that sounds good, it seems that the regulator is working fine:
1648715731125.png
Could you answer a few questions just to make sure we're on the same page:
  1. How do you power the computer? You clip your power supply directly to the battery terminals? If you use the 4pin Molex plug, make sure that you power both positive pins (using just one might fry some components). If you use the battery terminals, do you "close" the microswitch that switches between the battery and the 9V battery?
  2. How do you "turn on" the computer? After connecting the power, it's usually necessary to reset the Power Manager (reset + interrupt buttons pressed together for several seconds then release) and then press any keyboard key (sorry, maybe a trivial question).
  3. When you reset the Power Manager (with two buttons), does anything happen? I could hear a changing pitch in the speaker when I was doing that (connect power --> silent --> reset_pmgr --> silent --> spacebar --> static noise --> reset pmgr --> silent).
  4. Did you wash the board after recapping? To me, it sounds like you could have some remaining cap goo around the hybrid or the PMGR chip. You can safely wash the entire board in water, use an old toothbrush with soap in spots covered with goo and then dry it for several days.
  5. In my experience, 9V battery doesn't have to be connected if you power up the board using the Molex connector.

For the other signals I mentioned above, here is the pinout of the PDS connector:
1648715583628.png
It would be interesting to know what happens on the +5V lines (5/0 --> this powers the CPU, 5/3.7), SYS_RST, SYS_PWR.
 

nnn

Member
Thanks for the detailed diagram and questions.

Here are responses to your questions:
1. I used the bench power supply (picked up from Amazon) to power the computer by clipping directly on to battery terminals. I used couple of Q-tips to ensure that microswitch in the battery compartment is pressed down when I did the test.
2. I turned on the computer by pressing the space bar. But it does not always power on (drawing power and displaying the black screen).
I also tested the power on feature by pressing the reset button then the space bar but it shows the same result (black screen and no chime). I tried pressing the reset button on the side when it is on but it just shuts off.
3. When I reset the Power Manager, it is silent. There is no sound unless I hook up floppy disk drive. When the floppy disk drive is connected there is a single click noise when space bar is pressed to start the computer.
4. I only cleaned the area directly under the capacitors with isopropyl alcohol. Didn't clean the whole board. Will try that before testing the J12 connector.
5. I am not using the molex connector. Good to know that I don't have bother with the 9V battery.

Thank you for the diagram. That makes things much clear as to what have to test. I assume 5V line is the pin 25 on row A of J12. I will wash the board first and let them dry properly before doing the suggested test. I will report back once I completed the testing.
 

nnn

Member
I washed the board (rinsed with distilled water as well as IPA) and let it dry for almost 3 days.
When I powered it on with the bench power supply (supplying 6V and max of 1.3A), it resulted in the same symptom as before (except there is a slight noise when I turn on the computer).

As suggested, I tested the J12 pins (all are with computer powered on):
+5V VCC(5/3.7) on J12 row A pin 25 showed 5.19V.
SYS_PWR on J12 row B pin 5 showed 0.006V
SYS_RST on J12 row C pin 30 showed 0.476V

I should note that when probe of multimeter touched SYS_RST pin, screen changed from black to bunch of lines (no legible text or symbols).
 

techknight

Well-known member
sounds like the PMGR died. might need to isolate and control those lines seperately just to see, but youll get a CD34/CD36 sad mac regardless.
 

nnn

Member
Thanks you techknight. That was what I was afraid of. Given that PMGR chip is pretty unique and surface mounted chip, I will have to leave this as non-working computer for now.
 
Top