• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Macintosh portable backlit m5126 floppy issue


Active member
A good day to all fellow Macintosh enthusiasts

Special request to the portable experts:)
Maybe someone can help me with this

I recently acquired a Backlit portable m5126, and had it recapped with tantalum’s

Everything works…!
except for the floppy drives; internal, also swapped with another drive
an external floppy drive, or a floppyemu does not work internal- or external

when I leave the cable of the floppy drive connected, the boot gets slow, especially loading of the finder, and once, in a while, I hear, reading sound from the drive, and the axle is spinning a few times. This is without a disk!

Today I already took the board out again, and cleaned it with 96% alcohol.
now it’s drying, but does anybody have a good idea where I should look to repair?
Also am going to check the voltage with macometer when it’s dried up

I cannot see any broken traces, it’s really pristine
the board was looking really great round the caps

When one inserts a disk, the floppy does get gets ejected on boot, but no floppy with a cross or or question mark

One time at boot, I got the question from the OS, “initialize disk” when I had the floppy emu connected (strange: emu stuck on sector 02 and then resets to 00, never mounts) and a 1.4MB disk in the internal
Drive at that moment
It recognised the 1.4MB as a 800k disk, but cannot initialise it. After reboot the dialog of initialise did not come up again

SWIM trouble?
Can I swap this with swim from
SE or se/30 or LC?

PWMR trouble? Hard to believe, charging and using works brilliantly

Love to hear from you guys, am pretty happy with the working portable
But would be amazing to also have the floppy working…


Active member
Before the recap the Mac would not boot, would bomb while Loading extensions
But at that time I tried a floppy upon boot and greeted me with a floppy with a cross
So this behaviour is definitely changed


Well-known member
I was about to start a thread with much the same problem; backlit Portable, freshly recapped, floppy drive now detects a disk when there is not one there AND same floppy drive works perfectly in another Portable. A different drive has the same fault when tried in the first machine.

I think a stray capacitor pin had found its way across pins of the largest VLSI chip on the right side of the board. However, removing this has made no difference. Cleaning the board seems to make a temporary, slight improvement (it nearly booted off a floppy, where normally it will not read the floppy at all).

I’m about to try swapping the SWIM chip tomorrow. I’ll use one from a PB100 logic board.