• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Macintosh 512K Sad Mac and Speaker pops

Howdy 68kmla'rs!

I was given a Macintosh 512K that was in very rough shape. As is common, the battery had leaked and the whole chassis was covered in rust.

Phase 1
The computer actually showed signs of life even in this rough shape. After wiggling the cable between the logic board and analog board I was finally able to see a sad mac screen with a lot of artifacts.

First thing was to stabilize the analog board with some new capacitors and cleaning of the corroded traces. The logic board was also cleaned up and besides for a few places like the rear ports and bracket bar practically looks brand new.

Now the computer powers on properly and all voltage rails from the analog board look great.

Turning the computer on and many times the speaker would simply pop, occasionally it would make it to the sad mac screen.

Phase 2
Even though the sad mac screen had heavily distortion and artifacts I was able to look up the sad mac codes and determine the failure was in the ROM check.

Sure enough, verifying the ROM chips against known good ROM images pointed to one of the chips having many read errors.

After some fiddling with the TL866II Plus programmer and some fresh EEPROMS I was able to flash the replacement ROMs.

With the new ROMS inserted I was presented with yet another sad mac code. Interestingly since swapping the ROMs it has ceased making the normal startup beep.

The results are generally the same when trying the original 64K ROM for the 512K and even with various versions of the Plus 128K ROMS.

Phase 3
The new sad mac codes pointed to RAM issues, which seemed obvious enough with the amount of artifacts on the screen.

First I went ahead and socketed all 16 RAM chips, the artifacts were bad enough that the sad mac codes did not fully translate to particular Bits/Chips. In the end I was able to identify a total of 3 bad RAM chips. Replacing these with something similar would clear the error in that Bit/Chip.

However... It's still not behaving as it should. Once the new chips are all inserted and the Mac is able to successfully check the ROM and RAM. It goes to a grey screen, no mouse cursor, though no mouse is connected, I am not sure if this is normal.

It stays on the grey screen for a couple of seconds before I hear distorted and popping sounds from the speaker until the screen goes black entirely.

If I pull one of the RAM chips it goes back to showing the sad mac screen with the obvious error about that chip being removed. With all chips inserted I would have expected either another error code or to finally see the happy mac or question floppy icon.

Brick Wall
Looking at the schematics it appears the RAM is directly connected to the CPU with signals coming from the BMU0/BMU1 chips for things like chip select and/or address decoding. I am not seeing anything strange on the oscilloscope however.

With the ROM and RAM fully replaced it just seems like something else on the board is misbehaving. Something with activating the other peripherals like the IWM and Serial controller that there may be a bus conflict.

I am at the point where the only choice would be to start socketing other chips like the 74 LS logic. Unfortunately it doesn't appear the equations are known to burn new PAL/HAL chips, so if one of these is the problem it may simply be a lost cause.

Hoping that someone can recognize the symptoms and point me in the right direction and save this machine from the great scrapyard in the sky.

I dont have a floppy drive, but even using the Rominator it still never makes it to any sort of working state.
Some videos that may help

ROM and RAM replaced, Gray Screen, Speaker pops, no Sad Mac.

When any RAM chips are removed, Sad Mac

Based on this article: https://macgui.com/news/article.php?t=496

It seems the failure occurs when its done with all ROM and RAM tests and starts this stage:

Low-Level System Initialization

Let's take stock of what has happened thus far, if there have been no errors. The screen is black. The VIA was initialized. We heard the boot beep. The IWM was initialized. ROM was check-summed and the RAM was tested.

If the ROM test or RAM test failed, the infamous Sad Mac icon with error code will appear.

Since I don't hear the beep, could it be a bad 6522 or 8530? Totally stumped for the moment.
Some progress maybe,

I socketed the 6522 VIA and the adjacent 3440042 CLK chip.

With the CLK chip removed the results are the same with or without removing a ram chip.

However, with the VIA removed the mac goes straight to a black screen with no speaker pops.

With a RAM chip removed and the VIA removed, it goes to a sad mac for the ram error. This is interesting as evidently the VIA is not necessary at all for the basic ROM and RAM checks which produce the sad mac display.

I have ordered some hopefully compatible 6522 chips and will see if that makes any difference.
A little bit of further progress,

While waiting for the replacement 6522 VIA to arrive I have socketed the 8530, adjacent 4016, and IWM chip.

With the 8530 removed the behavior is the same. Speaker pops with RAM fully populated, sad mac with one RAM chip removed.

With the IWM removed the behavior is the same as having the VIA removed. Black screen with no speaker pops.

Interestingly with the IWM removed, I swear one time I heard the normal startup beep. Although there was still no display and I could not reproduce this condition.
Okay a bit of an update, really hoping someone knows what this means.

First, because I am impatient waiting for the replacement 6522 I have socketed the LAG and BMU0 PAL chips.

After socketing and reinserting the chips I got the checkerboard pattern. This seems to indicate that the video signal is still being generated and a stable pattern more or less means the RAM is okay, just uninitialized.

Trying to clean up the chips and reinserting them... I have inserted the LAG the wrong way and cooked the chip.

Such is life, however, some further progress and investigations.

Without the LAG chip the analog board goes into the constant reset and click of death.

Now.. does the LAG from a Plus logic board work in a 512K board.. well.. Yeah I think so :)

With a confirmed good LAG swapped in from a Plus logic board, the 512K board now goes back to the checkerboard pattern.

Moving right along, so now there is a new and pretty worse issue where at least I was getting gray/black and sad mac screens now all I see is the checkerboard pattern. Hitting reset and no joy.

Let's break out the scope.

First, I am seeing stable clocks approximately 8.3 Mhz on the CPU and 16.59 Mhz from the main oscillator.

Looking at the address lines and everything appears very strange, and the reset signal appears to be constantly being pulled low for very brief intervals.

So thats strange, connecting probes to both A1 and RESET on the CPU shows the reset line being pulled low and a few short pulses on the address line.

At first it seemed like some other chip could be disrupting these signals, so I have removed all the RAM chips, all LS logic, and other chips that have been socketed along the way, including the ROMs. This results in the same behavior, huh.

Looking at the diagrams, which is where I should have started, the LM311 is responsible for generating the RESET signal and handling the reset button press. Although the inputs to this chip seemed normal it was time to, you guessed it, socket the LM311 as well.

Well with the LM311 removed, again the same result in the CPU seemingly constantly resetting itself.

Comparing to the Plus board, the reset signal looks completely normal, being low momentarily and then high. With pressing the reset button pulling the signal low briefly and then high again.

Long winded question, does anyone know why the 68000 CPU would be in a constant RESET cycle?

Gosh, please someone say something before I go socketing this bad boy, 64 pins... ugh.
Pic of the socketed 512K board so far.


Ignore the wires attached to the CPU, this was to test a Rominator that is similarly not working with thus board.

What a journey, even though this post didn't get much love, thanks for inspiring me all the same. Seeing the posts here definitely kept me going back to this project with new ideas.

So what did I try, well, everything. But with all major chips socketed and known good replacements it still didn't work.

It all seemed to point to an issue with the board, maybe the corrosion finally had its way, perhaps the stress of socketing so many chips finally cooked the board. Well.. Nope.

Going back to basics I started to tone (ohm) out major connections, address and data lines between the ROMs, CPU, and PAL chips. These seemed okay, same results from when I had started. Checking for shorts between address lines and.... AH HA! Several address lines were shorted together, this could easily result in a resetting CPU and checkerboard pattern.

But removing the CPU, ROMs, and PAL chips, the short remained. Sufficiently stumped at this point and near the end of my rope with this board I went decidedly "low tech". Using my bench supply at 3 volts connected across two of the shorted address lines and, something started to get warm.

So what was it?? A resistor pack.. package E3 providing pull-up resistors to several address lines. How?? I am at a loss on this one.

This component worked at one point enough to get the sad mac screens, and must have failed with heat applied from the desoldering process.

If anyone's curious I'll do a wrap up post about the things actually wrong with this Mac. In total it was 6 bad chips plus one that I personally cooked myself for good measure.



Well-known member

What a journey, even though this post didn't get much love, thanks for inspiring me all the same. Seeing the posts here definitely kept me going back to this project with new ideas

Thank you for taking the time to document your experiences. I’ve found it just now, because I’m just beginning my journey with a 512K board, or more correctly two 512K boards. One seems like it has a short… so I’ll check the resistor packs :) the other has the correct startup sound but produces a Sad Mac error. I’ll get a bit further when I’ve repaired the analog board’s lack of vertical size, hopefully by replacing a zener diode. But the vertical lines all over the Sad Mac make me suspect a RAM fault.

Anyway, thanks again for slogging on and taking the time to post. Someone somewhere will enjoy it eventually, e.g. me
Finally got this little 512K Mac put back together with a couple of interesting new faults along the way.

Just in time for the last day of #MARCHintosh!

Special thanks to the community here in the 68kmla forums and shoutout to @tashtari for the excellent TashTwenty project and @reallyrandy for donating this machine!