• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Head scratcher and Pismo Chipsets


Well-known member
So I was having issues with my Pismo 500Mhz G3. I noticed first that I was having issues with my Cardbus expansion. The airport card worked, but I couldn't get a device to power up, or even have OS X recognize that the Cardbus slot actually existed. So I started playing around and the next thing I know the USB dropped off the machine.

So I went through the rigor-marole and did the PRAM/Power-Manager resets and while it got the USB back, I still had no Cardbus.

I didn't get to it till tonight, but I decided I would tear down the laptop and reseat EVERYTHING.

I took it down so far that I even took off the card-cage and reattached it to the board. But the thought occurred while I was looking at the board and the processor module.

It struck me weird, but think the chipset for this laptop is on the same daughter-board as the CPU. Leaving pretty much the PCI bus hanging off the connector from the daughter-card to the logic-board.

Am I right in thinking that the only thing that gender-neutral PDS slot is to get the data and power to the CPU and chipset? if that is true, it could have been that some of the pins didn't connect.

Because once I checked everything and it put it back together, sure enough the Cardbus started working. Keep in mind the airport card was working, but being able to use my Cardbus wireless card and USB 2.0 card is a huge thing for me on this laptop.

So I would like someone to chime in. Seeing the Texas Instruments large chip (as well as the ATI chip) made me think that the sole purpose of that connector is to get power/data in and out of the board to the CPU. In which case may be the reason why those cards are so freaking expensive when it comes to do upgrades. The fact that they would have to get chips, the ROM and the CPU for companies to make upgrades would make a huge deal of sense when they wanted you to send your old board into them as a swap. It was just too expensive compared to something like the daughter-board on the Beige/B&W G3 was where all it was was the CPU and cache.

I would like to hear from some of the more engineering-esque people as this might clear up for some people why certain things work and certain things don't, leading to the question "Did you try removing the daughter-card and re-seating it?" rather than "it might be xxx" when the problem may be that the pins didn't contact to send the data.

Thoughts? comments. I know doing that fixed my issue. I highly doubt pulling and re-seating the card cage did it as before I did it, I pushed down to try to seat it and it wouldn't budge and instead made me take it apart to re-seat it.

Thanks and sorry I haven't been posting much, been real busy between school and work.

EDIT part of the reason I thought this is that the Cardbus controller is actually on the logicboard leading me to think the data wasn't getting from that chip to the chipset to tell it it existed on the bus.



Staff member
I've never been inside a "Pismo", but on the tray-loading iMacs which use a similar sort of CPU card the main system controller (MPC106) is indeed located on the processor card. (In essence making entire motherboard little more than a collection of PCI peripherals.) Given how the Pismo CPU card likewise has the RAM slots on it it's a fair bet it also has the UNI-N system controller on it. And if that's the case then a bad connection could certainly cause all sorts of havoc with anything sitting on the PCI bus, and that would include the Cardbus bridge IC.

(On the flip side, however, I would think that a problem like that would probably pretty much brick the whole system at once but I suppose it's *possible* that the Cardbus controller is more demanding of the bus than the USB controller.)

You do know, of course, that all the "CPU upgrade cards" they sell for the Pismo are just Apple cards with the original CPU melted off and a new one soldered to the same board, right? That's why the upgrades don't go any faster than a 500Mhz G4 or the 900Mhz G3s; those are the fastest CPUs which are pin-compatible with the stock G3. In principle a manufacturer could make faster cards by melting all the support chips off the stock boards and transferring them to a new-build card but given the difficulty in reusing surface-mount components I suspect such a board would cost a mint. (The other possibility would be to insert some sort of adapter/carrier between the BGA pads on the stock card and the new CPU, but that's also "really hard".) Parts like the UNI-N aren't available on the open market, so a full new-build card is basically an impossibility. (If they were available then systems like those ridonkulous "PowerPC Amiga" machines that people keep trying to build wouldn't be so eternally stuck as vaporware. The biggest hurdle the makers of those things have to face is that nobody but Apple made a good desktop-oriented PPC Northbridge. Motorola/Freescale didn't bother because their primary non-Apple customers were embedded system manufacturers. Network routers don't need AGP.)



Well-known member

You're not that far off. Normally, in most cases, a problem like that turns out to be a loose ribbon cable; one that wasn't securely connected to begin with or excessive heat worked it loose. But still, re-seating the connections should fix the problem. As far as the ATI chip on the daughter card, I think that may be a chipset; probably an early form of Northbridge, since it's physically connected to the RAM and CPU. The so-called Southbridge would be a second chipset on the logic board, probably located directly underneath the daughter card, so that the 2 chips take advantage of the short bus connections to and fro.

Just yesterday I had to tear mine apart to install the replacement hinges in the LCD display, but didn't have enough time to verify what I had in my Pismo. I haven't experienced the same problems you've been having, but there have been some fluke moments in the past, where I couldn't get any response from the USB. Restarting the Pismo did solve the problem. It might have been from excessive heat during normal use, but that only happens if I am running Firefox and/or watching Youtube videos.

73s de Phreakout. :rambo:



Active member
From my Pismo memories (may she rest in peace) I think you're basically correct. I remember, when I got my upgrade (I think it was a 900 MHz one) that, in order to upgrade, the CPU had to be removed from the daughter card and a new one soldered into its place. I also remember, from taking mine apart, that once you got the daughter card/RAM off, there wasn't much to the thing. There was a separate board with the audio on it and the trackpad, but most of the Pismo was CD/DVD drive, battery and HD.