• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Apple IIc - no beep, no drive seek, no video (maybe) - worth repairing?


Well-known member
A friend gave me an Apple IIc that hasn't been used in decades. It worked when it was last used. It was dusty but appeared in good condition. He no longer had the power supply, mouse, or any of the disks. So I ordered a power supply online (yikes the originals are pricey!). I got the PSU and connected it up and powered on the IIc, but I get no beep and no disk drive seek sounds, just a green power LED and silence...

I tried connecting a VGA monitor to the DB15 connector on the back, but either the IIc isn't sending any signal or my monitor couldn't understand it. I'll try connecting composite video later - I have to dig out another monitor for that.

My questions are: considering the no beep and no drive seek at boot, do you think this IIc is worth repairing?
What are some common causes for no beep and no drive seek at boot?

I honestly don't know anything about Apple IIc's and if I were to get it running, it would just be to sell it and give my friend some cash. He was nice enough to give me a LOT of classic Mac stuff (more than just this IIc), I'd like to give a little back to him.

Thanks in advance,


Well-known member
Hard to say.
the DB15 on the back was used for several adaptors, including the sought after but not really usable lcd screen.
No way any VGA display will handle the signal.
Composite is the way to go here.
Probably a ram issue, but anything is possible. Last units had a ram test in Rom.
The IIc can handle a great range of voltages with a some hack.


Well-known member
Some progress this morning...
  • Composite video works!
  • On first boot, floppy drive seeks
  • On first boot, you get a nice POST beep
  • On first boot, it displays the "Apple IIc" insert disk screen. (I don't have any IIc disks)
  • Consecutive boots fail and show more and more garbage on the screen. The floppy doesn't seek and you don't get a POST beep.
  • If you unplug the power supply and leave it off for a few seconds, then plug it back in, it will boot fine. (I'm calling this a first boot), but if you just turn it off and back on, you get garbage on the screen. The more times you do it, the more garbage you get.
I haven't opened up the case on this IIc yet to inspect the internals. From pics on the web, I see there's only one electrolytic capacitor... is recapping a thing for IIc's? I don't see a PRAM battery. Do IIc's even have them?


Well-known member
No capacitor surgery required, no Pram battery.
Keep in mind that the IIc is expecting a floppy to « go ahead « and that flipping the switch off and on is not the expected behavior for the IIc.
As said previously, last units had a self-test (both apple keys -Control-reset)

still thinking probably a ram issue if you have garbage, but without using a floppy (MECC inspector) for instance, no way to go further ahead.


Well-known member
The garbage you're seeing on screen is normal for the age of the machine. My //c does the same thing (also one of my //e's). From what I understand, it has something to do with the aging of the RAM chips. Older chips seem to retain their memory for a bit after power-off, causing glitches when rapidly power-cycled. The good news is that you don't need to unplug your machine. Just wait a few seconds between turning it off and on. If you need to rapidly reboot, then press "CONTROL-Open/hollow Apple-RESET". This will not only reboot the //c but clear the RAM as well.

To run the internal diagnostic press "CONTROL-Closed/solid Apple-RESET".

Other than that, happy computing!


Well-known member
Even back when, fast cycling would leave garbage in RAM.

Yes, as my moustache-laden linebacker computer teacher used to say in elementary school: "CONTROL-HOOOOPEN-APPLE-RESET!" for any problem that we encountered, no matter what it was.


Well-known member
Thanks gentlemen! I truly appreciate the help. Now... I have to figure out how to get the floppyEMU working and get this booted properly.

First I'll give the on-board diags a try. I hope it has the later ROM...


Well-known member
Hooray! I have ROM v3 and the built-in diags come back "System OK", which is awesome.

I'm having trouble getting it to recognize my floppy EMU plugged into the external drive port. Since the IIc is working properly, I really don't want to take it apart and risk snapping any brittle plastics just to plug the floppy EMU into the internal drive port... Anyone have any better ideas? I don't have anything that will write the old 5.25 Apple II disks, so making new ones isn't an option for me.


Well-known member
Unfortunately, the //c defaults to the internal drive when booting from 5.25 disks. I believe you can still boot 3.5 (800k) and smart HDD images externally, but you will probably need to open the computer and attach the EMU to the internal 20 pin socket to boot a 5.25 (140k) image.


Well-known member
I dug around on Big Mess O Wires site a bit and found:
  • You can't boot from floppy EMU 5.25" images while it is plugged in externally
  • You CAN boot from Smart Drive images while plugged in externally, if you set the correct mode via text file on the EMU's config
So that's what I did, and booted from BMOW's Smart image and ran a few games to make sure everything worked. Seems like it works. There were some weird things that I will just chalk up to not knowing anything about the IIc and not knowing the games' configurations. I couldn't get it to go into ProDOS from BMOW's image, which I thought was strange, and the utilities didn't work for me either. But I played Dig Dug and a Moon Patrol.

So I'm calling this Apple IIc working as it should. Thanks again for the assistance!


Well-known member
Great to hear! These are fun little machines, I use my IIc quite a bit. If your emu has the IIe diagnostics image (it'll boot as a IIc diagnostic, if I remember correctly), I'd recommend running the RAM tests to be sure everything is copacetic on that front ---- I don't have an emu so I don't know if the issues you're seeing are normal or not, but it does seem strange to me that you can't load ProDOS. Hopefully someone else can shed some light.

I'd recommend sourcing a 4X ROM so that you can boot from the external floppy port if you like, but also run the later ROM's on-board diagnostic as well (which, if there's an issue, let you know which chip is potentially misbehaving). In any event the 4X is a nice upgrade if you plan on using the machine somewhat regularly.