• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

400K Drive Fails To Initialize 99% Of the Time! But IF successful, will boot from the disk.


So I recently Purchased a donor 400k drive to fix my Original 128K Macintosh Floppy drive.

I transplanted the head, which the old ones 0 sensor arm got deformed by me, lol. Lubricated everything, and tried to format. Keep in mind, my zero sensors is wrong, I am not really focusing on that quiet yet. Although I moved it many of times in hopes I was misaligned with the Stepper motor. No change for formatting a disk. I have not and will not touch the Stepper screws unless absolutely necessary

The head moves all the way down like it should, then goes to verify, this is when it usually fails. Sometimes in the middle of the disk, and sometimes right at the end. And sometimes every once in a while, it formats absolutely perfectly, and I can read, write, and even Boot from the 400k drive. Mounts every single time, ect. No problems it seemed. I have verified the Felt pad pressure, and contact with the head/disk

But here's the weird part, this morning, these exact same reliable disks failed to read on this same drive. And I touched nothing, the drive just sat overnight unpowered. All I did was add some more oil, and let it soak on the Stepper, and leadscrew.

"What in these drives can drift overnight to cause this change?" My only thought is capacitors, although I highly, highly doubt it. My head is spinning trying to figure this out. It really should not be this difficult!! I have a recapped Controller board I can try later today which I have not tried in this drive yet, but I never recapped the Main motor speed board yet. So theirs still that possibility.

Any leads on this?
I have a video here of it booting up last night on this drive and its own unique disks.

But again, then today "I TOUCHED NOTHING" and it can no longer read any of the successfully formatted disks I made last night. And my 0 sensor is cranked very tight. I checked all screws and nothing has wiggled loose. Any leads of this one?

I just want my beloved 128K set complete again!! It's in brand new condition, carrying bag and everything!! My pride and joy has been out of commission for years!



I just realized something. Is their a Head height adjustment screw somewhere? Since I transplanted this head FROM THE donor drive, mabye its not perfectly aligned for this assembly. Is the screw at the bottom of the Leadscrew, with the DAB of nail polish the head height ajustment? I have to remove the controller board to access that. But is that a possibility DUE TO Transplanted head assembly from other drive?

I feel as if im very close. Something is just slightly out of alighment. Or caps. IDK> JEEZ!!!!!!!


My experience is that having lubricated my 400K OA-D34V-22 drive it absolutely would not work at all without the aluminium mounting bracket around it, and even then it was a bit finicky about where it was put relative to the analogue board. However, once I remounted everything in the chassis it has become completely reliable. So perhaps the heads and amplifiers in these drives are rather sensitive to EMI?