• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

3400c backlight issue

techknight

Well-known member
Here is a new one. When I last monkeyed with the 3400c I owned, everything worked fine, even the battery held a charge. I pulled the PRAM battery as it was showing signs of starting to leak. this was years ago. 

I just so happened to pull it out today to recharge the battery, and check it out, and noticed the backlight had failed. its lightning up sort of, with the screen about half-way lit. and its flickering quite a bit. 

Maybe inverter failure. 

I havent pulled it apart, but I am curious if anyone has run into this before? does the inverter have caps on it that start leaking or something? Just curious. 

 

LCARS

Well-known member
I have not run into this problem but it inspired me browse through the Repair Source manual (I'll include it). Page 11 suggests that if the backlight doesn't operate after checking connections, replace inverter board. The board layout is on page 177 but not that clear. If the caps are the same as other boards, they might have failed. Hopefully that and not something harder to replace. 

Have you tried resetting the power manager?

View attachment powerbook_3400c.g3.pdf

 

techknight

Well-known member
Figured it out. 

Apparently I forgot to clean the PCB after I removed the leaking PRAM battery about 10 years ago. So guess what. the left over corrosion had eaten something away. because the backlight will come and go depend on where I put my finger on the motherboard. 

 
Top