Jump to content

Clamshell left hinge screw


Recommended Posts

  • 68kMLA Supporter

I have two iBook clamshells I’ve been working on. I stripped them down this far, but in both cases I got stuck at the screw holding the left hinge, the one dead center in this photo:

ibook-left-hinge.thumb.jpg.e93d131b36683e31e9fc7e14cd06310c.jpg

 

It turns freely, but won’t come out. There’s enough of a gap for the grounding cable to rotate, though. I tried forcing the screw upwards, but didn’t make any progress. The screw on the right hinge comes out without any trouble.

 

A stuck screw is no surprise, but I wasn’t expecting to get stuck on the same screw in both iBooks. Is there something I’m missing? Is there something about this specific screw? Any advice on how to proceed?

Link to post
Share on other sites
  • 68kMLA Supporter

I tried, but I didn’t make any progress. There’s not really room to get much leverage there. I also tried inserting a coin under the hinge, but that didn’t help either. There might be room to slip a thin wrench underneath to keep the insert from turning, if I knew what size was appropriate. (assuming the insert is hex-shaped)

 

I guess the extreme option is to cut the head off the screw or drill it out. I don’t have the tools for that, though.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...