Jump to content

Cardbus ethernet

Recommended Posts

Can anyone recommend a cardbus-compliant ethernet card for a PowerBook 2400c?


I went WPA on my home network and now cannot connect wirelessly in MacOS 8.6, so need an alternative to look for on eBay. An older 16-bit card that I had for a Powerbook 190 is painfully slow -- so painfully slow that it may be on the way out. A 32 bit card (I gather they have an on-board processor too) might make all the difference.


I have googled but haven't been able to find useful information; however, someone on here may know the exact series to go for to suit a machine this old.

Link to post
Share on other sites
  • 3 weeks later...

If you're accustomed to the speed of wireless, then the speed difference between a 16 bit and 32 bit PCMCIA is not going to matter much. Even the slowest byte mode of 16 bit PCMCIA is a little less than 4 MB/sec and I'm certain the 2400 supports word mode at faster rates (which would be 20 MB/sec; the card might not, but all cards I've ever seen support word mode at least, which is a about 7.8 MB/sec).


Try it. It may have been either the older PowerBook which was a factor, the driver, or both.

Link to post
Share on other sites
  • 5 months later...

Could you guys make recommendations on specific cards that would work with a PowerBook 5300CE?


My machine with OS 7.5.5 has a GlobalVillage A930 modem/ethernet card, but sadly the dongles are missing so it's quite useless. You can find a few of these cards on Ebay but they are all "card only" which I take to mean no dongles...


Recommendations for alternatives would be greatly appreciated.

Link to post
Share on other sites

Well, I tried it, and it worked great. I had a system error on the first boot, but rebooting without extensions and manually moving a bunch of junk from Extensions to Disabled Extensions solved the problem.


FWIW this is a used Mac with a lot of older software on it. Next thing will be a fresh install of 7.5.5 and getting Ethernet working, but I'm sure I'll manage.


Thanks for the tips. The 3C589 cards are pretty easy to come by on the 'bay.

Link to post
Share on other sites

It wasn't the simple one-off bomb mentioned on your site - I kept clicking Restart and the error message kept reappearing without an actual reboot taking place. Pulled the power, booted with Shift pressed down, went into Extensions and moved a bunch of stuff (including Apple Built-in Ethernet) to Disabled Extensions (for some reasons these did not appear in Extension Manager where I first tried disabling Ethernet stuff as per the install instructions), and everything started working.


Thanks for your work on this. It's a very useful piece of software. When I get around to doing a clean install I'll post here with any interesting lessons learned, if any - but it'll probably take me a week to get around to playing with a 7.5 reinstall as I'm totally swamped with work right now.

Link to post
Share on other sites

So I'm happy to report that the clean install of 7.5.5 went without a hitch.


I zapped the HD, installed 7.5.3, updated to 7.5.5. Installed Stuffit Expander then Open Transport 1.1.2.


I moved the "Ethernet (Built-in)" extension into the "Extensions (Disabled)" folder, dropped your driver into Extensions, and rebooted. When the system was loading it when through an unexpected reboot (I think this is where I was supposed to get a System Error) but upon going through the motions again it booted fine.


I opened the TCP/IP control panel, selected "Alternate Ethernet" as the NIC, installed iCab, and presto, I was online.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...