Jump to content

Recommended Posts

I picked up a Classic II yesterday for $3 at a church rummage sale. Today I finally got the chance to power it on and check it out. Unfortunately I was greeted with this: IMG_0605 No bong no resone from the KB/Mouse, and nothing but a cramped blank screen.

 

So I opened it up and saw some capacitor goo, expected, and some corrosion. I cleaned up some of it with some alcohol and a q-tip. I tried it again, but to no avail. Here's a picture of the worst corrosion. IMG_0606

 

So I remembered a spare Classic I board, and tried it in place of the II board. It turned on to this: IMG_0604 Partial success!

 

I'll make a post in the compact forums, but does these symptoms ring a bell to anyone?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...