Jump to content

Apple Lisa doesn't boot - need help troubleshooting

Recommended Posts

I have some Lisa parts that I acquired over time and would like to get running.  My issues don't seem to follow any of the other threads or guides that are out there, so after thrashing about quite some time, I am hoping someone has enough experience to help definitively identify what the issues are so that I can get it to at least boot.  From there I think that I could sort things out.


Here are the parts that I have:

2 Lisa 2's (1 is missing the faceplate, neither has a hard drive, 1 has the floppy drive and cage)

2-1/2 power supplies (1 recapped, 1 purchased as 'working', 1 that is missing the transformer)

1 profile drive and cable

1 keyboard and (mac mouse)

2 card cages

the following boards

2 motherboards

620-0108-c recapped, traces checked, no other parts replaced

620-0108-e recapped, traces checked, no other parts replaced, 1 IO board connection was broken, so I ran a trace wire in its place

3 IO boards

620-0117-m (2/5) This one had a battery backup that I removed, was recapped, cleaned and checked for continuity (fixed a single trace that I found broken), replaced three transistors that were iffy.

620-0117-j (2/5) This one had a battery backup had been removed, was recapped, and had connectors that were replaced, but it is in rough shape, unsure continuity, generally not included in testing

620-0142-e (2/10) This one did not have a battery backup and is in excellent physical appearance - no replacement of parts, continuity that has been tested is fine

1 CPU board

2 Memory cards (512MB)


Here is what I have done:

power supply recapped one (filter caps were fine and were not replaced), other was supposed to be working

motherboard (see above)

IO board (see above)


I have read that the minimum assembly to boot is the card cage, motherboard and IO board, so I installed those, put in the power supply, defeated the 2 case switches (no mouse or keyboard attached) plug it in and the power button instantly lights up.


Allowing a case switch to close turns off the power light and there is an audible click.  This happens with either Lisa, either PS, either MB and either IO board.


Suggestions on how to check out a power supply, without it being installed in the Lisa


Suggestions for where to check or what to try next?

Edited by Juror22
Link to post
Share on other sites

in my opinion you need the processor card as well, no sure it could work without.


I have one at home at the moment, should try to boot it also.

I believe the "motherboard" is what he was calling the CPU board.


The power circuit is controlled by the COP421. Verify it and the socket is in good condition as it lives very close to where the battery lives.




The power-on should consist of two audible pops from the speaker (and either an image on the screen, or just a raster at around the same time), two more clicks in succession followed by any error codes detected by the system being beeped out. You can force it to beep an error code by simply not plugging a keyboard in.


For testing the power supply remove the side skin panel closest to the power supply and CRT and you should see the harness connection for the power supply. The pinout for the Widget and non-widget power supplies are the same, so using that as a pin reference you should be able to verify +5, +12 and +5StandBy. Those are your basic rails and all three are needed.


Also, you have Lisa2 cases but are they Lisa 2/5 or 2/10? There are differences that personally I've never been able to test but I assume are incompatible.

Edited by CelGen
Link to post
Share on other sites

Re power supply testing:


I tested my recently recapped Lisa PSUs on the bench by hooking up dummy loads (power resistors) to the +5, +12, and +33 volt rails. With these set up, you can check the voltages on all the rails to see if everything is in spec.


Start by looking at the specs for the power supply in a copy of the Lisa Hardware Manual, like this one:




where PDF page 259 has the specs you need. Apply Ohm's Law to figure out resistor values to use to keep the current draw within the bounds specified for the three positive rails, and make sure that you use resistors that are capable of dissipating the dozen or two watts that you're going to pump through them.


You can't run a 1.2A PSU without loads on these rails---the voltages will go far enough out of spec for the PSU's crowbar circuit to repeatedly "reboot" the power supply (making a clicking noise you can hear). We found that the -12v rail does not need a load in spite of the 0.01A minimum current spec, at least for a brief test.


The PSU is nominally off when it's plugged in with nothing (or only the dummy loads) attached. In this state, though, the separate 5v standby supply is still active. You can test this voltage without a load, which is the thing to do first.


Once you're ready to turn the PSU on, in addition to setting the dummy loads in place, you will need to connect the 5v rail to the 5v sense line (so that the PSU can monitor itself) and the 5v standby supply to the on/off line (so that the PSU turns itself on). Both of these connections must be maintained for as long as you want to keep the PSU running. It seems fine to arrange all the hookups with the unit unplugged and then to plug the thing in so that it turns itself on immediately.


Some cryptic pinout information can be worked out from the schematic:




With the contacts on one side of the board labelled with numbers, and letters used for contacts on the other side (ambiguous letters like I and O are not used), you can work out what needs to be clipped where. It's a lucky break that there are no "hard" connections to clip for setting up the resistors and other connections---you can always clip right onto the edge connector, since it doesn't matter if the contacts on both sides at the places you'll need to clip are shorted. (In fact, this makes it easy to clip the +5v sense line to +5v.) This is not generally the case, but it is for the contacts you want to use.


Once the PSU is set up and plugged in, test all of the power rails for the right voltages. I try to be quick about it, since it's not clear to me whether leaving the -12v rail unloaded would be OK for an extended period.


Hope this helps!

Edited by stepleton
Link to post
Share on other sites

Thanks for the suggestions, tips and information.  I will perform the additional checking and report back.


The Lisa 2 cases are A6S0300's with mfg dates in '83, so between that and the interior cables, I think that they are compatible with the boards.  The only exception that I have found in researching this was that a 2/10 IO board requires modification to the Lisa Lite board to make the floppy functional http://lisafaq.sunder.net/single.html#lisafaq-hw-io


My PSU's (all) are the 1.8A units


I also recalled that there are a few additional procedures that I forgot to list above...

on the IO board 620-0117-m, I removed the battery switch, disassembled and cleaned it, then re-soldered it on.

on the motherboard 620-0108-c, I removed the mouse connector, renewed the connector pins and re-soldered it.

on the PSU that I recapped, I replaced the power transistors (2N6308).

Edited by Juror22
Link to post
Share on other sites


I believe the "motherboard" is what he was calling the CPU board.


Ok, the Lisa is probably the only Apple having a Motherboard (it's written on the board) and is the bottom board where all the other ones are connected to.

Link to post
Share on other sites

One obvious final thing I still always forget: make sure to defeat the interlock switch on the back of the PSU (near the video adjustment pots) while you're doing these tests. The +5v standby will work whether the interlock is defeated or not; the other rails won't.


Just wedging a piece of cardboard between the switch and the housing will do the job.

Link to post
Share on other sites

bibilit - I was looking for help and it is appreciated, I only learned about the differentiation a few months back, when I started paying a lot more attention to checking that board.


stepleton - That's true, it is the case switch that tags along and I've overlooked it before.  I use Q-tips® to defeat the interlocks, but cardboard is a good idea too.  I am trying to sort out the resisters required for the loads.  I really miss RadioShack, they were great for stuff like that, everything (where I live) is mail order now. :(

Edited by Juror22
Link to post
Share on other sites
  • 4 months later...

Ok - so I finally tested the Power supplies that I have and one is fine and the other is close to ok - the one that was re-capped is low on the sense [4.7V vs 5V] and standby [4.9V vs 5 or 5.7V], while the other one is dead on.  The only reading that is off is the -100V on pin B.  My understanding is that this originates outside the power supply in the video circuit.  


Is this true and where do I look next?  Instead of the expected -100V, it is reading +400V.  Any suggestions?

Link to post
Share on other sites

The hundreds-of-volts lines on the PSU are for video circuits that just pass through the PSU to get to the adjustment knobs on the back of the computer. The actual power supply circuitry doesn't interact with these in any way---back on the schematic, you can see that pins 1,2,3,A,B are isolated from all of the other circuitry.


If you are getting a +400V reading on any part of the edge connector while the PSU is on the bench (i.e. not in the Lisa) then something very strange is happening. Can you elaborate on what you're trying right now, and where you're taking measurements?



Link to post
Share on other sites

For reference. The schematic for the Lisa's analog board can be found here.

My guess is there is a problem with the brightness adjustment. I don't know what the grid voltage is on a Lisa but 400v sounds like the  potentiometer has gone open and the circuit is unloaded. The schematic shows spark gaps but I assume those only engage around 1000v.

Link to post
Share on other sites

Thanks for getting back so quickly - these results were with the PSU installed and the side panel off, card cage, motherboard and IO board installed and the 2 case switches defeated and with no mouse or keyboard attached.  I plug it in and the light on the power switch immediately comes on and I get the following measurements.




I assume that at this point I need to start looking outside the power supply for the issue that is preventing startup?

Edited by Juror22
Link to post
Share on other sites

That assessment sounds correct to me. For starters, the machine should not just turn on when you plug it in.


I'm not quite sure what to investigate next... I assume that when the PSU is plugged in, its +5v standby pin is effectively being shorted to its on/off pin at all times, which accounts for the "instant on" behaviour. Perhaps it would be good to find out why that is... it may be that a fault on the I/O board or the motherboard is to blame, and finding it might supply more clues.

Link to post
Share on other sites

I have three IO boards, so I swapped each one out. Both of the 2/5 boards acted the same (instant on as described above).  When I installed the 2/10 board, and applied power, the switch light did not instantly come on.  I pressed the on-off switch and it lit up, but there were no speaker pops and there was no CRT activity.


So, I pulled out the other Lisa and put the cage and PSU in that one and I saw the same behavior as in the first Lisa  - pressed the on-off switch, then it lit up, no speaker pops and no CRT activity.  The 2/10 board has no corrosion (no battery) and looks pristine, but the COP chip or other components could still be bad.  Is there a troubleshooting chart for the COP chip somewhere?  I haven't ruled out other problems on the board, but since the on/off switch behaves correctly, it seems like this one works better than the others and perhaps that might be the next thing to check.

Link to post
Share on other sites

I'm not sure from your description, but just as a quick check, do we know that your 2/5 behaves the same way with the other power supply (the one you haven't been trying to diagnose)? Does the other Lisa work with just the power supply you have been trying to diagnose (but with everything else in the "normal" configuration)?


It would be strange to me to find three I/O boards with three failed COPS chips, unless there was something about your Lisas that was frying them somehow. I am also not sure that the 2/10 board behaving differently from the 2/5 boards is diagnostic of anything other than the two boards being different, which they are in several respects. Other people here may know better, though.


It would be nice if swapping around your PSUs could help us eliminate some possible problems.

Link to post
Share on other sites

stepleton noted that there are two power supplies (I have the reading for each listed in the middle two columns of the pinout attachment) and they both give similar results, so I don't think it is a power supply issue any longer.  I'm thinking that one of the other components that is required to boot is the issue, either the CPU board, motherboard or the IO board.  I believe that the 2/10 board is the best I have and for now I will assume that it is working since the switch light comes on after it is pressed with the 2/10 IO board, irregardless of the Lisa, power supply or motherboard used.


I remember seeing a troubleshooting guide (in the Sun Lisa document?) so I'll see if I can look that up and go from there.

Edited by Juror22
Link to post
Share on other sites

From the 'Lisa Troubleshooting Guide' Rev. Apr 84, Page 6.l2


Incorrect or no video, no "clicks", and no error tones.
- I/O
- (Go to Video Repair Procedures)
- Motherboard
The troubleshooting method that they describe is to swap in working ones, to determine the bad card.  If someone has a different way to go about this, let me know.  Otherwise, I think I might just button them up and set them aside until I can get a working one to swap parts and determine which card is the issue.
Link to post
Share on other sites
  • 1 year later...

I have a very similar problem. I have two Lisas; one fully working and another that one of the main safety caps in the PSU had blown. They are both the Datapower 180W PSUs. I've replaced all 5 of the yellow boxy safety caps and the two huge round caps. 

I normally run power supplies through a 100W light bulb when testing to avoid nasty explosion (Jestine Yong tip) but this is preventing the Lisa from starting up. Whether I use the original PSU or the repaired PSU in the fully working Lisa, the power button light blinks on, status builds up on the screen, the 100W lamp pulses on momentarily (that's normal as the main input caps charge up) and then the Lisa powers off.

As the symptoms were identical for both PSUs, I was hopeful I had repaired the faulty one OK.

However, when I connect to the mains without going through the 100W bulb, the Lisa starts up fine with its original PSU but when I try with the repaired PSU, it trips the circuit breaker in my house.

I'm not quite sure how to proceed. I've read the above tips on how to set up the PSU to test on the bench but how do I test it if it trips the mains? My normal trick would be to use the 100W bulb but this seems to be preventing the power supply from starting up even though it is also preventing the mains from tripping.

Any suggestions would be appreciated.


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...