Jump to content

Search the Community

Showing results for tags 'cr-43'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Elseā€¦
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


FACEBOOK


GOOGLEPLUS


TWITTER


YOUTUBE


Location


Interests


OCCUPATION

Found 2 results

  1. Hi all, I've two Apple 20SC external SCSI enclosures, both of which had bad PSUs, notably Sony CR-43 parts. One was heavily corroded, and has been exposed to the elements (I did recap but no change - very low trickle voltage), the other pristine and used regularly but started blowing fuses suddenly (also recapped - fuses continued to blow, no evidence of shorts). I'm not comfortable with failing PSUs so decided it would be time for replacement. The original Sony CR-43 AC to DC dual voltage PSU is rated @ 50W, +12V 1.5A, +5V 2.0A. After some research, I cam
  2. Just uploaded my Apple Hard Disk 20SC recapping video, which also covers the 40SC, 80SC and 160SC since they all use the same SONY CR-43 PSU. Check the text description for a Mouser Cart and useful info. At the end, I do a boot test with a 2015 15" MBP.
×
×
  • Create New...