Jump to content
AlpineRaven

Macintosh Quadra 840av

Recommended Posts

I have this Quadra 840av board, it isn't working at this stage and I noticed two capacitors are missing on the bottom of the board suspected rough handling.

 

On the underside on the battery end side;

 

C399

C397

 

Really keen to fix this board up.

 

Does anyone know what voltage/value they would be?

Cheers

AP

Share this post


Link to post
Share on other sites

I can confirm they are both fitted to my board but there is no easy way to measure their values without removing them. They're quite inaccessible - behind the plastic board protector. How on earth did they get knocked off? Are you sure that they're not just unpopulated on your board?

Share this post


Link to post
Share on other sites
On 9/28/2020 at 2:31 AM, AlpineRaven said:

I have this Quadra 840av board, it isn't working at this stage

I noticed you don't mention what you've already done. I recommend (if you haven't already) remove all the electrolytic caps, give the board a thorough clean in distilled water and IPA. Clean all vias, chips and sockets. Replace all the capacitors. All of this before worrying about 2 random caps on the back :) Like Phil said, they're probably just unpopulated.

Edited by stormy
adding info

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×