Jump to content
Sign in to follow this  
saybur

IIci ADB Issues

Recommended Posts

I've got a troubled IIci and was hoping some wise soul here might have a good idea about what to try next.
 

This system boots up but does not register anything over ADB. Shaking the mouse during or after startup does nothing, nor does typing anything on a keyboard. After the machine boots, pressing the interrupt brings up the usual prompt.  This keyboard and mouse are my bench ones I use for testing machines and work on other systems. I verified that 5V is present on the ADB power pin and ~4.7V (or something similar, I don't quite recall) is on the data pin. Soft power from the keyboard also works fine.

 

I hooked up my oscilloscope to the data line to watch what it was doing, and it is... kind of weird. The edges are nice and clean but the data doesn't seem to make any sense: the normal sync, command byte, and stop bit are all there, but the system keeps sending a $FF command byte over and over again, long after the computer has finished booted. After shaking the mouse during bootup I can see it stretching the stop bit to do a service request, but the system never responds, and just keeps spamming $FF. The timings look OK, including between the transactions.  It's been a while since I worked with ADB, but I'm pretty sure $FF is an illegal command - Inside Macintosh says the addresses go through $E, and do not include $F, for what that's worth.


To get a comparison I hooked up my working IIci and snooped ADB on that.  It started by sending $1F, which makes more sense, and I did see a longer transaction when it probed the mouse without getting a service request.  The mouse worked after the system booted up.


This system came to me untested and I've done the normal work done on it:

 

  • I've replaced the existing electrolytics on the logic board, scrubbed affected areas with IPA, recapped, and dried 48 hours. There was more green rust than normal on several areas near the caps, which was also cleaned up.  This includes the area near the ADB chip, which was quite green, but I'm fairly confident it has been extensively cleaned.
  • The existing Astec PSU has been swapped with a known working Astec from the good IIci for testing. In operation it is showing 11.9V and 5.1V on the main rails (this is not a recapped unit, but I do have caps in the mail for both power supplies and intend to do that later).
  • HDD, expansion cards, and cache card have been pulled. I tried this with both the memory that came with the system and other, known-good SIMMs.


One other thing: when cold booting today, I did get a boot chime, followed a second or two later by death chimes and a black screen. The system was OK when rebooted. I left it off for 15 seconds and tried again, and the same thing happened, but the time between the boot chime and the death chimes was much longer, like 10 seconds or so. It didn't do it again afterwards, and did not do it before when I was first testing this machine. This prompted me to swap the memory with good sticks and leave the computer alone while I ate dinner.  When I came back, same basic thing: boot, then death chimes, then it was OK after repeated startups.

 

Sorry for the long post, and I appreciate everyone who took the time to read it.  If you have an idea, feel free to fire away.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×