Jump to content

Search the Community

Showing results for tags 'mains voltage'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Elseā€¦
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


FACEBOOK


GOOGLEPLUS


TWITTER


YOUTUBE


Location


Interests


OCCUPATION

Found 1 result

  1. Hi! New here Was going to post this here first, but as my activation email didn't get thrue until today, I posted this already in Reddit /r/vintageMac. I came across a local ad for a Mac 512K keyboard and mouse. Reading the ad, I noticed that it actually noted "a non-working Mac 512K can also be included". This was interesting as I rarely see Macs of this vintage locally, and this was only a short distance away from me. From the photos I could see that the machine was a 120V which was interesting (living in a 220V country). Ok, I went to bought the set for less than 100$. What I have observed so far: Serial number dates the unit to a late 1985 A battery was still inside, but it had leaked only a very little and after cleaning and scraping the battery contacts they look Ok. There was no damage to the PCB where the holder sits. The floppy drive is a Sony MP-F51W, meaning that it has been upgraded (800k) ROMs are 23512-1010 and 23512-1007 (ie. "old ROMs" if I am not mistaken?) The analog board is marked 630-0102-J (ie. US, 110V non-switchable?) The digital board looks pristine and all the solder joints look original as well. Keyboard (M0110, 1985 per serial) and mouse (M0100, 1985) look intact and are reasonably clean. Keyboard cable is missing (seller said he might still have it, I might get it later). Externally the computer is in average condition, only major issue being a burnt spot in the plastic at the top left (covering part of the vent and also a bit of the front panel's top). The two short T15 screws were missing, perhaps a repair-attempt was made but they never get the case open due to the two recessed screws in the handle-space I have not tried to power up the unit yet. There was no backstory of how it failed, but being a 120V set in a 220V country, it's most likely that it was plugged in without step-down transfomer and was struck with overvoltage mains. Looking at the analog board, I see very little obvious damage. The fuse and resistor R51 next to the mains input have obviously burnt. On the bottom of the board resistors R46, R47 and R49 have slight discoloration and all three had their values gone very high. I have also done some measurements according to the books "Macintosh_Repair_&_Upgrade_Secrets_1990" and "The_Dead_Mac_Scrolls_1992" (there are plenty of in-circuit resistance measurements to go by). At the moment I am thinking about replacing the obviously burnt (/gone-high value) resistors, keep measuring around to find anything else obvious, and then power up (with a proper step-down converter). Adding to a larger component order (need to do this during the weekend), I'll also buy some spares of the nearby components (next to the burnt resistors in the schematics) like Q11, Q9 and perhaps the opto-coupler U3 too? Also some electrolytics, but I am not bothing a full re-cap yet. At first I'd like to see if replacing the obvious faults would give me any signs of life. Now my main question is; has anyone experienced a similar 120/220V over-voltage repair? How much was damaged etc. Any other pointers on what to keep an eye on?
×