Jump to content

dcr

68000
  • Content Count

    1005
  • Joined

  • Last visited

About dcr

Recent Profile Visitors

1222 profile views
  1. dcr

    A very late 040

    We had an LC at the office back when they were new. It was used for our ordering system and probably word processing too. Pretty sure it wasn't the host computer but a workstation. And, as I recall, it worked fine for that. I believe we had it until the LCIIIs came out and then it was replaced with an LCIII. The LC was sold to a local government department where they used it for another couple years. (There's a chance it was an LCII, but I am pretty sure it was an LC.)
  2. dcr

    Y2K2020 Date Problem System 7

    Given that the first Mac was 1984 and the first Apple was 1976, there's not going to be any Apple or Mac files or applications dated before 1972. So, that seems the best option. Downside is the sorting might be off for the reason you mention, though I'm not sure if that will cause any problems for anything the computers are going to be used for. That is, I don't think they'll be running airplane schedules or anything. I would think primarily games and word processing. And, for me, if I create a file on July 30, 2042, if that shows up as July 30, 2042 (and I can move it to a then-modern computer and preserve that date), that works for me. I would imagine, though, in the case where the clock battery is dead, the system might default to January 1, 2041 instead of January 1, 1904? (Or February 6, 2040?) Not a major problem but just a change to get used to.
  3. dcr

    Y2K2020 Date Problem System 7

    The clock uses a 32-bit number to keep track of the number of seconds from January 1, 1904. This runs out in February of 2040. After that, it will revert to 1904. It affects the HFS and HFS+ file systems too. AFS fixes the problem but, of course, that will only work on versions of Mac OS X that support AFS.
  4. dcr

    Y2K2020 Date Problem System 7

    But your old Macs might not!! :-P Or the Earth. On the plus side, maybe time travel will have been invented before 2042. Then, you can go back well before 2042 and not need to worry about the clock again. Also, NOS will be replaced with NNS.
  5. Following up on this, here is what I did last night . . . 1. Tried a different monitor. No go. Same problem with the other monitor. 2. Removed the VRAM SIMMs. A light layer of dust but otherwise appeared clean, especially the contacts. Cleaned everything anyway. Also swapped the positions of the two SIMMs. Still no go. Same problem with the monitor. 3. Moved the VRAM SIMMs to the two empty slots just in case it was a problem with the sockets. Still no go. 4. Replaced the VRAM SIMMs with a pair of VRAM SIMMs from another 8600, known to be working. Still no go. 5. Put the original VRAM SIMMs back in their original positions because, at this point, why not? Still no go. Don't see any issues with the logic board. No signs of leaking capacitors or any damage to any traces or anything. No leaking battery. No fishy odors. There was a good amount of dust inside the machine but not excessively so. I cleaned that out on the first go around. I did install an ATI Rage 128 Mac Edition PCI card in this machine (discussed in another thread) and hooked it up to a VGA LCD monitor. That worked without any problems. Still, I would like to figure out, if possible, what the problem might be with the built-in video. Kind of a waste to use the Rage 128 card in this machine. It's a server, so basic 640x480 is just fine for the rare times I need to use the monitor. Any ideas? Thanks again!
  6. The Power Mac is running 9.1 and the card worked without any issues. Thanks!
  7. Cool. Thanks! I think the Power Mac is running Mac OS 9.
  8. Does anyone know if the ATI Rage 128 Mac Edition PCI would be compatible with a Power Mac 8600? All I've been able to find online is that it requires Mac OS 8.0 or higher and a 33 MHz or 66 MHz PCI slot. A PM 8600 can run Mac OS 8 or higher, so no problem there, but I've not found anything on the MHz of the PCI slot.
  9. dcr

    Plus project

    I had the same problem with one of mine. First time, I had just remelted the existing solder. That worked for a while, but then had problems again. Second time, I removed and replaced the solder. Also, I hit every solder point that looked questionable. Third time, basically the same thing, remove and replace, hit every questionable point and even some that looked fine. Last few times I booted, it was still fine. If I've broken the trend, it should be fine the next time I boot it up. If not, I guess the resoldering will be an annual event.
  10. dcr

    The most interesting Mac Classic graffiti

    Rog/Roy/Ray/Rag may have been of the mind that if someone scrawls something in semi-permanent ink or worse on his computer, that person is definitely not the one.
  11. Plus, considering these machines lasted 10, 15, 20 years without problems (for the most part), the capacitors weren't so cheap after all. It's only frustrating for those of us now who want to keep using these older machines that we have to either develop advanced soldering skills or try to track down someone else who can replace capacitors and make any necessary repairs.
  12. dcr

    System 7 on a Rasberry Pi

    Recently? No. Haven't tried lately either. I did get it working through RetroPie a number of years ago on a Raspberry Pi B (I think). Downside was that you had to use the Emulation Station to get to it. That build used Basilisk II as opposed to Mini vMac. I've seen another video where the guy managed to get Basilisk II installed and configured where the Raspberry Pi would boot right into the emulator after going through its own startup process. That's my goal but haven't figured out how to do that. I have gotten it (Basilisk II) to run on a Raspberry Pi Zero but it has to go into the Raspbian desktop first and then you boot the Mac emulator. That leaves less memory for the Mac itself because the Raspbian desktop is running. Other problem I had was that the RPiZ would also lose the keyboard and mouse connection (USB) after a few minutes. Then, I'd have to unplug them and plug them back in to get them working again. Makes no sense to me. And that's not an emulator issue because it does it in Raspbian's desktop too.
  13. I'm using a laser engraver to make a portable-ish 640x480 LED display if that counts. Of course, mainly I'm ruining acrylic sheets, but, hopefully, I'll get there. Would have had the main panel finished if not for neglecting an important change from revision 1 to revision 2 that I thought was so obvious I didn't write it down but didn't actually remember until after revision 2 was cut out.
  14. Do you have any dead pens yet? They must have some kind of cartridge or reservoir to hold ink, so I wonder if there might be some way of refilling them?
  15. Just following up on this which I have neglected for far too long. No definite date yet, but I am hoping to have the newsletter ready for release in late summer. So if anyone wants to participate, there's still time. @RC14 @gobabushka If still interested, PM me.
×