Jump to content
  • Posts

    • If you haven't tried a known good set of ram I'd do that, my se/30 showed this with bad ram. Seems like you've tested almost everything else!
    • Hi All, and thanks for having me here.   It seems I'm yet another person with a Mac Classic that is dead.   It was working fine up to about 6 months ago and would happily boot from its internal hard disk. I put it to one side as I had other projects on the go, as I'm mainly to be found on ST forums as a mod and a repairer, but despite their similarities, my knowledge of the Mac Classic is limited.   I have done a lot of research though, and spent a lot of time trying to get a handle on this problem, which is this screen at boot time:     No bong or sad Mac, just the checkerboard.   So far this is what I've done.   1. Removed the 7 capacitors that are known to leak on the logic board, and replaced with tantalum equivalents. Note the picture of the mobo shows C5 and C9 missing, these were taken out to troubleshoot a non-existent short, but have been subsequently refitted.
      2. Cleaned the area around the caps with IPA and thoroughly washed the logic board in soapy water and dried for 48 Hours.
      3. Replaced the leaking PSU capacitors on the analog board.
      4. Possibly killed the ROM. It has a 42 pin socket, and for 40 pin ROMs should be plugged in starting at pin 2. I mistakenly plugged into pin 1 after cleaning the pins on the ROM, and it got rather warm.   I should say that despite the leaky caps on the analog board, none appears to have got down to the logic board, and neither has the battery leaked. A very small amount of electrolyte was present around the 7 electrolytics, but no corrosion was visible and it has been thoroughly cleaned.   Here is the logic board:     Whilst I suspect the ROM because of my hamfistedness, I'm not sure it's bad, as I tried a ROM emulator today, both with normal and byteswapped images just in case, but I get the same image on screen. I also get the same image on screen with no ROM installed, so I think this is something more fundamental than the ROM. Also, the /CE signal at the ROM is high, suggesting it's not active. I am wondering if RAM is the problem.   I'd even be inclined to say that it isn't even getting to the stage where the ROM is accessed. CPU has a clock of just under 8Mhz (7.834Mhz to be exact) and the /HALT & /RESET lines are high. Checking online the CLK speed should be 7.8336Mhz, so that's 100% fine.   I've been over the PCB with my microscope, and can't see any shorts or corrosion and I don't see any corrosion on the underside either.   I should also note that after changing the PSU caps on the analog board, voltages were low under load, so 4.77v and 11.6v respectively, so I have tweaked and now get a stable 5v and 12.2v. The HDD spins up at power on too.   Having done everything suggested that I can find on the web, I'm a bit stuck as to what's next. The only things I haven't yet done are to re-flow (re-solder!) the power lead at the analog board and change the optocoupler on the analog board, and I have some of those on the way, but other than that, I'm at a bit of a loss.   If there are any other possibilities and suggestions out there, I'd be glad to hear them as I want to get this machine back up and running. The trouble is, unlike with the STs, where I have experience, and diagnostic tools (Plus I own a stack of them), I know very little about the Mac Classic, other than the schematics I have.    Thanks in advance!
    • Well it had a jumper on "Term Power" on the 300e. Tried removing it and still the same outcome. Tried both passive and active terminators, various SCSI ID's and on different PowerBooks. All same old.   I can understand in your case not working on XT's, that's a completely different kind of beast, but one would think that if it works on desktops should work on PowerBook's since they speak the same language logically.   Also found and tried using my external SCSI HD. As remembered, it booted and saw that just fine. 
    • It's been a long time since I had a NeXT, and luckily I never had to troubleshoot mine.   There is a good chance recapping the logic board may fix it.   I'm rooting for you, I wish I'd never sold my NeXT, good luck with yours!
    • So I've been restoring a couple of WGS 9150s. One is an original (80mhz) and the other a 9150/120.   The 9150/80 was exhibiting these issues regularly: crashing with type 1, type 2, and type 3 errors after some usage internal video sometimes had random pixels of noise (in random colours) here and there occasionally the internal video also didn't work, just a black screen on boot   I figured this was all probably RAM related. I removed all the SIMMs and the problems were still there. So then I suspected its 8mb of DRAM soldered to the board.   At this point I decided I might as well replace the 18 electrolytic caps on the logicboard and give it a good clean. The insides were rammed with dust and fluff! I think this machine had sat on someone's floor for years just sucking in all the dirt. It was quite a gross job.   Anyway it's all clean and has shiny new caps installed.   Now it doesn't seem to crash any more, but I get no internal video on boot, just a black screen. My monitor (an NEC 1880FX) knows there's something there as it comes off standby when I boot the machine, but it never gets a full signal.   (as a side note - video works fine from a Nubus card)   Anyone got any ideas? I suspect one or more of the DRAM chips has failed... or something else?   I've searched for schematics in vain. Not sure where to go next diagnosing this.