Jump to content
directive0

Powerbook 5300c Revival.

Recommended Posts

Hey all!

 

Preface:

I had a Powerbook 5300c with a cracked screen, Beachycove gave me a 5300c with a dislodged power socket. With the magic of screwdrivers, solder and take apart guides I now have a (mostly functional) Powerbook 5300c that is an amalgam of the two! Thanks to this process I had two IDE HDs to try. I booted the laptop with Beachycove's HD and got the question-disk. Replaced the drive with the HD that came from my 5300c and got another question-disk. So okay -I thought- I've had great success with CF on my 7100 so I ordered a PCMCIA->CF adapter and waited!

 

Method

IMG_20130326_085639.thumb.jpg.33d4b9fd635e16093d9301f1195018b4.jpg

 

Well it came the other day and I decided to try it out using the CF I formatted and had installed in my PM7100's Aztec CF->SCSI adapter. The card was an 8Gig card with a system 8.5 disk and just popped it into the adapter, put the adapter into the book and booted up; success.

 

IMG_20130325_234228.thumb.jpg.d38172cf60375767410bf14dc429caad.jpg

 

I shut down, removed the card and mounted it on my MacPro in Tiger to copy the system folder off this 8Gig card and copy it onto the 4 gig CF card. I used tiger to partition it to many different setups; 1 partition, 2 partitions, 4 partitions. All formatted as HFS (mac os standard). Sometimes partitioning worked, sometimes it didn't; I would often only get one partition to work before Disk Utility would stop without report and leave the rest of the partitions unmounted. I tried restoring the disk from a Mac OS 8 installer image I had made but no luck there either. No matter what I tried the system gives me a question-disk and then forcibly ejects the card. My goal is to get OS 9 on both this powerbook and my 7100 in the future so I would like to acquire the magic skill of transferring system folders and disk images to external media. I gave up on the 4 gig card and went back to the 8Gig that I know works.

 

So now I want to get the internal drive working. It seems unlikely to me that both drives are completely hosed. I booted up Drive Setup to see if there was anything there, but it only recognizes the 8Gig card. Is this indicative of anything? I can still hear the drive spinning.

 

IMG_20130325_222638.thumb.jpg.00f43910179213a93ab38fc1aad8edbc.jpg

 

Conclusions

The machine runs MORE than competently on the CF card in the card slot, in fact it runs circles around my big clunky 7100/80. File browsing and applications are snappy, and I've only had one instance where the finder crashed from a memory famine. The screen size leaves much to be desired but I found an external video cable for it so I will eventually try to use that, despite the screen having those classic colours I've always loved. Its so good to have this little guy back. I remember stealing it from my dad's bag at the cottage to mess around with Spin Doctor and Super Maze Wars, or use Photoshop Elements that came with his Olympus digital camera to superimpose flying saucers on our sunset photos. HA. I was spoiled, man.

 

Future Goals

-I also bought an IDE->CF adapter so eventually I want to replace the internal drive with a card permanently.

-I want to get this networked.

-I want to install OS 9 on it.

 

So...I ASK 68k MLA:

-Are my 4 gig card headaches an issue with the type of card or do you reckon the 4Gig card itself is borked or somehow otherwise unsuitable?

 

-Is it possible to use any standard PCMCIA->Ethernet adapter with this laptop for networking, do I need to steer clear of cardbus cards?

 

-What software title would you recommend I track down to properly assess the drives that are connected. Is there anyway to see whats on the chain but not mounted? If this software is included in a specific Apple install or diagnostic disk could you please tell me the name?

 

-Does anyone have a link to some helpful advice regarding restoring disk images to existing either HD or CF partitions? I appreciate tutorials if you have them, or a thread here regarding the same topics.

 

Bonus Photos

 

IMG_20130325_234327.thumb.jpg.6e0841fe91f3840c17ae3b556d444f1b.jpg

 

 

 

Thanks for reading!

IMG_20130325_222306.thumb.jpg.16f187711fd97d17b1e295fc2c6309e4.jpg

Edited by Guest

Share this post


Link to post
Share on other sites

There used to be a page out there somewhere about installing a cf card in a 5300. I think it was on a blog. As I recall, the partitioning needed to be done on another machine in that case, or prior to installation via booting from the hd and working with the cf card in a pcmcia adapter — or something — i.e., there did seem to be peculiarities.

 

I looked at it some years ago when I put a cf in a 2300c, but I did not have the same runaround with that machine in the end. The cf card worked from the start.

Share this post


Link to post
Share on other sites

I have a similar setup with my 5300cs. Instead of an Ethernet card I use a WaveLAN PCMCIA Wifi card from ebay. (Not a Dell or Proxim card). With that I can get online with System 7.5.5. My "rescue disk" is a 32MB SD card in a PCMCIA adapter! (from dx, of course.) I also replaced the internal HD with a 1GB CF card and adapter. I think I initialized the disk while booted from the SD card, and installed to it from a disk image mounted over AppleShare.

 

I find System 7.5.5 to be a little unstable, freezing and bombing often. I might have some corrupted system files. With OS 7.6 installed, I get "bus error" on boot. I will try OS 8.1 next. I like to try the older versions in the hopes of having a faster system.

 

Have you had success so far getting online and getting OS 9 installed?

Share this post


Link to post
Share on other sites
system 8.5

MacOS 8.6 is a free upgrade & bugfix for 8.5: it is highly recommended over 8.5, which tended to be a little unstable. 8.6 is also a trifle less RAM hungry than 9.x

do you reckon the 4Gig card itself is borked

That would be my guess. Have you tried running any low-level diagnostics on the card? Checked/verified/repaired in Disk Utility, or some flash-specific diagnostics?

any standard PCMCIA->Ethernet adapter

You definitely need one with available Mac drivers compatible with your OS release. System 7 Today may have a list someplace.

(Incidentally, have you considered 7.6.1, or 8.1 for this machine?)

do I need to steer clear of cardbus cards?

Yes. This is not a CardBus slot. 16 bit PC Card/PCMCIA only.

 

With OS 7.6 installed, I get "bus error" on boot.

That's odd. Straight 7.6, or 7.6.1? (IIRC, the .1 release fixed a few minor bugs)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×