• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

SCSI2SD Problems After Crash

ian1035nr

Active member
Howdy, everyone

I’ve got a PowerBook 170 equipped with a 2.5”, V5.0 SCSI2SD drive that tends to misbehave after a system crash. 
 

I don’t get crashes very often (only when I forget to turn off extensions that are known to cause problems) but when I do, the PowerBook will no longer boot off the SCSI2SD. 
 

It sits at the floppy disk icon with a flashing question mark, and never finds a bootable system folder. 
 

I did find a work around: If I boot off a floppy disk, the SCSI2SD is visible and the PowerBook will boot from it the next time I power on the laptop. 
 

The whole thing is strange and I have no idea why it’s like this, it was never an issue with the HDD. I’d like to solve this so I don’t have to make sure I bring a bootable floppy with me every time I leave the house with my PowerBook. So if anyone has any ideas, I’m open to suggestions. 
 

the PowerBook is running Mac OS 7.6.1 and it was a clean install I performed on the 8GB SD card that came with the SCSI2SD. I configured the card to limit the partition size to 1GB. 

 

tjjq44

Well-known member
Hi can’t tell specifically for SCSI2SD but I had encountered this issue many times in the past with real Hard disks!! Forced to boot from a floppy to make my HD bootable again...

 

ian1035nr

Active member
Ah, beans.

I was kind of hoping it was a SCSI2SD specific issue, since it'd likely either be something I can't do anything about, or requires some changes to the configuration. But if the same thing can happen with regular HDDs, then that opens up more potential causes. One of these days I'm going to try reformatting with a patched version of Apple HD SC and do a clean install to see if that helps. As of right now, the system was formatted with LIDO and restored from a backup-up image from the old drive.

 
Top