• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Powerbook G3 266 Wallstreet Fan starts with any power


Well-known member
All glory is fleeting. I found reasonable looking untested powerbook G3 266. Initially on powering up, chime, hard drive clicked, clicked then a flashing disk on a reasonably good screen. I started up several times (and left it on) with an installation CD for 9.2.2 and 8.6. Great..it works, but need a hard drive. It was an easy, quick change from a broken 4.3 gb to an available 80 GB drive. After the hard drive change, on plugging in the power, the fan immediately turns on and stays on at high speed. No chime, no screen, just fan and steady LED. The power button has no effect. I can turn it (fan and LED only)  off and on by pressing shift-fn-ctrl-pwr.I Let it sit with the battery, without the battery, with the old hard drive, without any hard drive, without memory and its all the same...plug in power, fan on at high speed, led on, can turn on and off with the above key combination.

If I take this apart, should I disconnect the PRAM battery and leave it disconnected....what else should I replace while I'm in there. It is a complete dissasembly to get to the PRAM battery...history has proven, I only have a limited number of disassembles before something goes. I do note it is drawing 7.6 watts when the fan is on, but nothing when plugged in and off....but the main battery has never had any LED even after leaving plugged in when it was booting.



Well-known member
First, try to reseat the processor card; it may have been knocked loose during the hard drive swap. 

Most of these older PowerBooks had a specific sequence for battery charging: main battery to 100% first, then PRAM battery. If there's no main battery or it's no good, PRAM doesn't get charged. 

It's difficult to pinpoint the problems with these without a lot of spare modules to swap. I too have an early WallStreet (233, no cache, 13.3") that worked fine and then recently just quit with the same symptoms. Supposedly this indicates a failed processor card. Reseating my processor card and switching RAM around had no effect, nor did disconnecting the PRAM battery; it's still stuck at green light/screaming fan, even after a few days of sitting with no power. Maybe one day I'll worry about fixing it but with as much money as I've thrown at these over the years to diagnose their various failures (processor cards, power manager cards, LCDs, power/sound cards, charge cards, etc) I'll just wait until I have access to my old pile of parts rather than spend more money on guessing what has failed.



Well-known member
Update: I being absolutely foolish asa far as how joyful this 20 year old computer booting has made me.The hard drive installation went so smoothly, there was no way, no way, I thought, I did physical macro damage or dislodging of components. I didn't remove the CPU card, as Franklinstien recommended....I pressed down where it seated and it was firm and still the same result... screaming fan and led. With little confidence of a different result I took the CPU card out. I removed all memory then replaced the memory on the removed card.  With the CPU card out and the keyboard still attached, I powered the computer up (with the result LED and full steam fan once again), reset the PMU (shift-fn-ctrl-pwr) then removed all power and replaced the CPU card. When reattaching the power supply, about 0.5 sec LED and Fan, then press power button.....CHIME.....about 7-10 seconds of silence then flashing disc question mark. It was back.

Now running 9.2.2 with SD to ATA.

Thank you Mr. Franklinstein....you are the man.




Well-known member
Good job!

Sometimes, corrosion will interfere with an otherwise firm connection and prevent things form working. The best way to ensure that that isn't happening, I've found, is to completely undo the connection (remove the CPU card) and reinsert, perhaps several times (this scrapes off some of the corrosion and allows for proper contact).

It might be prudent to spray the CPU card connectors and RAM slots with some contact cleaner to prevent this from happening again.




Well-known member
I get the same issue when plugging the adaptor into my 250MHz Wallstreet, but it lasts for about 5 seconds then turns off. Then I can boot the machine normally. I've had the processor card out a few times due to other maintenance but it hasn't changed the result. I will try resetting the PMU this evening and report back.