• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Mac 512k L2 Coil hot

Hello, just restored a nice 512k.
All electrolitics in the analog board have been recaped.

Every thing works nicely, the only thing I noted is the coil (in the analog board - check image) named L2 that get hot, about 80 °C.

Is this temperature normal or there is something I have to check?

Thanks for any suggestion.

IMG_0546.jpg
 

joshc

Well-known member
Pretty sure that's most likely normal; these boards are known for running on the hot side in general, especially around the flyback area.

You need to replace the cracked/damaged RIFA filter capacitor, these blow dramatically and are quite smelly when they go. Only replace with the same type, looks like this one is an X class 0.47 uF one.

1637708758237.png
 
Pretty sure that's most likely normal; these boards are known for running on the hot side in general, especially around the flyback area.

You need to replace the cracked/damaged RIFA filter capacitor, these blow dramatically and are quite smelly when they go. Only replace with the same type, looks like this one is an X class 0.47 uF one.

View attachment 36352

Yes, the picture is before recap, I replaced it with same type/value and 275V instead 250V.

IMG_0561.jpg

Anyway I decided to recap all electrolytics with others having equal/greater voltage, a part the one in le left of the coil that was 3.9uF unpolarized that I did not found but it is in good conditions and everything works fine.

So ok, I'm going to leave this coil to warm up the room a little :)

Thanks!
 
Last edited:
Top