• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Color classic headphone/speaker out not working correctly

Verault

Well-known member
Pretty sure C8 is supposed to connect to that via next to the negative capacitor pad and not where the bodge runs, also what’s the pin touching something here in this area?
Those pads were damaged so the caps are run to the next trace off the original contact. Those are fine and not the issue.
 

Verault

Well-known member
I took the chip off yesterday and I can see with a scope pretty far under it. I really dont see a short. I think its elsewhere on the board.

Or the chip is internally shorted.
 

Verault

Well-known member
This gets stranger.. Maybe I have found nothing. I just checked the dead LC575 board (which now is missing the DFAC2 and the Audio jack. The pads on the board where DFAC2 used to be show continuity between pads 37 and 38!

Do you have a color classic? I could really use the insight of someone testing on a real board.

I also traced out continuity from pins 37/38 and they go to the Microphone jack not the headphone jack.

the schematic has the JAck right (J2) but it calls it "PHONES JACK" which is wrong.
 
Last edited:

jajan547

Well-known member
This gets stranger.. Maybe I have found nothing. I just checked the dead LC575 board (which now is missing the DFAC2 and the Audio jack. The pads on the board where DFAC2 used to be show continuity between pads 37 and 38!

Do you have a color classic? I could really use the insight of someone testing on a real board.

I also traced out continuity from pins 37/38 and they go to the Microphone jack not the headphone jack.
I have one with the mystic mod and a CC2 with the stick board I have two color classic logic boards but had to have both sent to a friend because there was some pretty severe cap damage to the pads and battery damage on the ram pads and LS chips on the other plus no sound lol
 

Verault

Well-known member
I have one with the mystic mod and a CC2 with the stick board I have two color classic logic boards but had to have both sent to a friend because there was some pretty severe cap damage to the pads and battery damage on the ram pads and LS chips on the other plus no sound lol
Any luck?
 

jajan547

Well-known member
Any luck?
Could honestly be a bad chip it's not uncommon on Color Classics, and you did verify this chip worked fine on the donor board? You can bypass the external speaker I forget what to do but I know that if you bypass it and still no sound through the headphone jack then I suspect it's the Jack.
 
Top