Jump to content

Recommended Posts

  • 68kMLA Supporter
Posted (edited)

I'm following @Mk.558's guide (http://www.applefool.com/se30/#afpnetwork) as best I can, trying to connect a IIci running 7.5.3 to a Mini G4 running 10.4.11 over Appletalk on Ethernet. I can see the Mini in the Chooser (and the Mini can see the IIci in Classic), I can enter the user info, but then I get the error "The connection to this server has unexpectedly been broken."

  • The IIci is using OpenTransport 3.1 and AppleShare Client 3.7.4
  • The IIci can mount a G3 running 9.2.2, and vice versa
  • The G3 can mount the Mini, and vice versa

 

What could I be missing? Is 7.5.5 required? Thoughts?

Edited by desertrout
Link to post
Share on other sites

10.4 doesn't do AFP over appletalk -- only IP, you need ethernet and to be using the IP address or hostname for this to work. Your chooser should have a "server IP address" button when you've clicked on appletalk or appleshare -- try to use that.

 

I have mostly the same setup but i haven't tested it with 7.5, does your 10.4 machine have all the patches and is it a client or server installation?

Link to post
Share on other sites
  • 68kMLA Supporter
20 hours ago, History_SE30_Dude said:

Is AppleTalk turned on on the mini in the network control panel for whatever interface it’s connected to the network with?

 

Yep

 

19 hours ago, Cory5412 said:

10.4 doesn't do AFP over appletalk -- only IP, you need ethernet and to be using the IP address or hostname for this to work. Your chooser should have a "server IP address" button when you've clicked on appletalk or appleshare -- try to use that.

 

I have mostly the same setup but i haven't tested it with 7.5, does your 10.4 machine have all the patches and is it a client or server installation?

 

Huh, I must have misunderstood the documentation. I'm (obviously) pretty unfamiliar with the nuances of Apple networking, it seems kinda labyrinthine at times. Getting more familiar with it is one of the reasons I'm messing around.

 

I've tried the IP address of the Mini in Chooser, but I get a 'No response from server' error. I'm doing some further testing with the IIci, thinking there may be some other connectivity issues.

 

I believe the Mini has all the updates, but I'm not sure what you mean if it's a client or server install... :-/

Link to post
Share on other sites

My apologies for the confusion: it's probably the client version, the server version has loads of extra server-specific stuff installed. I think the compatibility between the two is the same, but I'm not 100% sure on that, and haven't tested for a few years. Basically, Apple sometimes built wider compatibility into the server versions of things. If not, and yours is a G4 mini you can revert back to 10.3 and get old apple files over appletalk back as well.

 

As far as I can tell you have the versions of everything correct and I think I've heard people report this works for them on 7.5.3 before.

 

I'd check on the other networking things.

 

One other thought, in the TCP/IP control panel, you may need to make sure that TCP/IP turns on automatically when your system boots. To do that, use the mode selector at the bottom right to change to advanced or admin mode, then, I believe there's a settings or options panel in one of the menus, there's a checkbox in there to automatically load TCP/IP and connect to the network when the system starts.

 

If you don't do that, the system waits until a TCP/IP application requests a connection which can cause some slowness and inconsistent behavior. (Do this at least for testing but I'm aware a IIci isn't the hottest and fastest Quadra so I would understand if you want to revert back to TCP being available only on demand.)

 

If you're manually addressing both systems, make sure neither conflicts with your home network's DHCP range, make sure there's no wifi between them since that can make things weird, make sure the subnet masks match, if you're using a firewall and VLANs make sure TCP port 548 is allowed between the two networks. (I think it's fine if its' just that machines from the client net can initiate 548 connections to the server, unless you want to connect to your IIci from the OSX machine.)

 

20 hours ago, desertrout said:

it seems kinda labyrinthine at times

It absolutely is. This is always a problem with technical things, For me to go "oh just..." is backed up by 20 years of having used these these systems and 15 or so of doing networking and file sharing and it's important to remember that, so my very apolgoies if I came off as brusque or terse.

Link to post
Share on other sites
  • 68kMLA Supporter

Update: The fact that the IIci couldn't connect to the Internet was suspicious to me, even though it could connect to other machines on the network via Ethernet (like the G3). So I went into the TCP/IP control panel and manually setting the addresses, verified Internet connectivity with Netscape (68k.news / frogfind.com FTW), and now I'm able to connect to the Mini via Appleshare in the Chooser. Not using the IP address, just by selecting it from the list of file servers.

Link to post
Share on other sites
  • 68kMLA Supporter
Posted (edited)
20 hours ago, Cory5412 said:

One other thought, in the TCP/IP control panel, you may need to make sure that TCP/IP turns on automatically when your system boots. To do that, use the mode selector at the bottom right to change to advanced or admin mode, then, I believe there's a settings or options panel in one of the menus, there's a checkbox in there to automatically load TCP/IP and connect to the network when the system starts.

 

I'll try this next.

 

20 hours ago, Cory5412 said:

It absolutely is. This is always a problem with technical things, For me to go "oh just..." is backed up by 20 years of having used these these systems and 15 or so of doing networking and file sharing and it's important to remember that, so my very apolgoies if I came off as brusque or terse.

 

Haha, I get it. No worries, and thanks for the insights. :)

Edited by desertrout
Link to post
Share on other sites
20 hours ago, desertrout said:

and now I'm able to connect to the Mini via Appleshare in the Chooser. Not using the IP address, just by selecting it from the list of file servers.

 

Yay! So it's being smart enough to switch over to the IP connectivity on its own. Great to hear this is now working!

 

 

Link to post
Share on other sites
  • 68kMLA Supporter
20 hours ago, Cory5412 said:

One other thought, in the TCP/IP control panel, you may need to make sure that TCP/IP turns on automatically when your system boots. To do that, use the mode selector at the bottom right to change to advanced or admin mode, then, I believe there's a settings or options panel in one of the menus, there's a checkbox in there to automatically load TCP/IP and connect to the network when the system starts.

 

This doesn't seem to be an option in 7.5.3..... though perhaps you were talking about doing this on the Mini, in which case it's already like that and working as expected.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...