Jump to content

LaserWriter IIsc Blinking Lights and Driver?


Recommended Posts

  • 68kMLA Supporter

I finally lugged my 50-pound LaserWriter IIsc in from sitting in the trunk of my car for a couple weeks. This is the first laser printer I've owned, and would like to get it up and working with my vintage Macs so I can do more experimentation with desktop publishing.

 

After plugging the LaserWriter in, it sprung to life. However, after connecting it to my Mac and loading the paper feeder tray, all lights went out except the two right lights that blink continuously. Anyone know what these mean? The printer looks to be in pristine condition inside and out, and the previous owner said it worked 20 years ago and has been untouched since.

IMG_5216.thumb.jpg.2c4bb3fba8299762f750f8233354195f.jpg

 

My other problem is locating driver software for this printer. I couldn't find any driver software for the IIsc specifically, but located driver software for the Personal LaserWriter SC in the System 7 setup disks on my FloppyEmu. Will these drivers work, and are there drivers I can use in System 6?

LaserWriter-chooser.png.69b30f34e3a48646a45b1e5ed0599f6c.png

 

Also, does the IIsc and any LaserWriters have RIFA caps or anything that can go 'bang'? My particular IIsc was made in October 1989.

 

Any help would be greatly appreciated.

 

Link to post
Share on other sites
  • 68kMLA Supporter
Posted (edited)
21 hours ago, sstaylor said:

"LaserWriter" driver should work, if I recall correctly. Might have been a LaserWriter IIsc driver but I don't think so.

"Personal LaserWriter" not likely to work.

The LaserWriter IIsc and Personal LaserWriter SC are special ducks in that they use SCSI exclusively and connect directly to the computer instead of AppleTalk. Thus, I don’t believe if the standard LaserWriter driver works.

 

 Is there any more info on the IIsc, such as a manual? I did a quick search and couldn’t find much on this specific model outside the basics.

 

Edit: I found a manual that suggests the flashes mean a I/O board issue. What would potentially cause that?

Edited by Garrett
Link to post
Share on other sites
21 hours ago, Garrett said:

Edit: I found a manual that suggests the flashes mean a I/O board issue. What would potentially cause that?

 

Caps.  You know it, sad to say.  LaserWriters also needed a decent clean regularly of rollers etc. for reliable use.

Edited by Byrd
Link to post
Share on other sites
  • 68kMLA Supporter
On 4/23/2021 at 5:50 AM, Byrd said:

 

Caps.  You know it, sad to say.  LaserWriters also needed a decent clean regularly of rollers etc. for reliable use.

I was hoping my IIsc would dodge the capacitor plague, but it seems likely that bad caps have something to do with this issue. Especially when the repair manual even mentions a capacitor needing to be discharged.

 

 How hard is it to remove and recap the IIsc board? Did they make the switch to surface-mount caps by the IIsc, or will it still use through-hole caps?

 

 How do you clean these? I’m new to LaserWriters as well as to laser printers in general.

 

 Thanks

Link to post
Share on other sites
22 hours ago, Garrett said:

How hard is it to remove and recap the IIsc board? Did they make the switch to surface-mount caps by the IIsc, or will it still use through-hole caps?

 

How do you clean these? I’m new to LaserWriters as well as to laser printers in general.

 

The LaserWriter I/O board should slide right out for visual inspection of the caps.

 

But yes I'd do a clean of everything before pulling out the soldering iron; there are lots of common parts to a laser printed, slide out what you can and clean with isopropyl alcohol wipes (using something like a soft hair brush to dislodge any crud) - things like rollers, trays, cartridges.

 

laserwriter_ii.pdf

Edited by Byrd
Link to post
Share on other sites
  • 68kMLA Supporter
Posted (edited)
21 hours ago, Byrd said:

The LaserWriter I/O board should slide right out for visual inspection of the caps.

I pulled the board out tonight and gave it a look over, especially near the three electrolytic capacitors on the board. At least to me, it doesn’t look horrible. But then again, looks can be deceiving.

 

487CBA9C-07A1-4FDD-B9AA-4A5E7DFBFEE9.thumb.jpeg.7ab5e1f455da79a67d3919562d61ea89.jpeg

 

After reinstalling the board, I set the SCSI input number to 7 for it to automatically print a test page. While it’s supposed to print a test page, it didn’t. The second light from the right (page icon) remained illuminated for about 2-3 minutes (no other lights on) before the printer acted like it was restarting and the two right lights started blinking continuously again.

 

I noticed I don’t have a SCSI terminator. Would that cause these issues, including it not wanting to print test pages?

Edited by Garrett
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...