Jump to content

Looking for : HiRes 840av motherboard photos


Recommended Posts

Hi Everyone,

 

   Just wondering if someone has high resolution pictures of the 840av motherboard, where individual traces can be distinguished. I bought a broken 840av with acid damage and would like to attempt to fix it.

 

Thank you

Link to post
Share on other sites

You may also want to look at schematics: look for "Macintosh Quadra 840av Schematic (bomarc).pdf" on Google.

 

Those motherboards are worth saving ! Also don't loose 2 month of debugging like be because you plugged your ADB keyboard on the S-Video port.

 

Good luck !

Link to post
Share on other sites

Thanks for the replies everyone.

 

@demik Thanks for the tip :) I fear I may have bitten off more than I can chew with this one, I bought the machine feeling nostalgic.. oh well.. oh well, I'll take it as a learning journey. Those schematics in the pdf are detailed, thanks! They will come in handy, but as I'm a noob it may take a while to navigate them.

 

I noticed C385 has been ripped right off the motherboard, so I'll need to replace it as a start.

 

The case came in rightful crap state.. I'm not daring enough to use the power supply that came with it. Time to find a way to test the thing first.

Link to post
Share on other sites
On 2/23/2021 at 3:20 AM, Kai Robinson said:

*pokes head in*

Did someone say reproduction board? :D

 

Haha :D This one will be one hell of a challenge…

 

@casper I will be working on my 840av board next week. If you need some pictures, please post what you need here

Edited by demik
Link to post
Share on other sites
On 2/17/2021 at 1:54 AM, casper said:

The case came in rightful crap state.. I'm not daring enough to use the power supply that came with it. Time to find a way to test the thing first.

I worked through this with my Quadra 840av last fall. I evenually got it working with more bodge wires than I care to admit!

 

I did create an adapter board to use a standard ATX power supply, if you're concerned about it. I think I still have a couple left hanging around somewhere.

https://github.com/akuker/mAcTX_Quadra_840av

Link to post
Share on other sites
  • 3 weeks later...
On 2/24/2021 at 12:08 AM, landoGriffin said:

I worked through this with my Quadra 840av last fall. I evenually got it working with more bodge wires than I care to admit!

What were the problems you ran into with the atx power supply?

I had trouble with my 840av just shutting itself off after a few seconds with the atx power supply i tried to adapt, but it runs fine now on a stock supply scavenged from another mac. I would love to modernize it so it doesn't suddenly blow up further down the road though, and I have another 840av that might still be recoverable but didn't show much sign of life on a bench supply...

 

Link to post
Share on other sites
On 3/12/2021 at 12:28 PM, error1 said:

What were the problems you ran into with the atx power supply?

I had trouble with my 840av just shutting itself off after a few seconds with the atx power supply i tried to adapt, but it runs fine now on a stock supply scavenged from another mac. I would love to modernize it so it doesn't suddenly blow up further down the road though, and I have another 840av that might still be recoverable but didn't show much sign of life on a bench supply...

 

I think in the end, the original power supply was fine. I have an issue where it will take a LOOOONG time to power up if it hasnt been running for a while. I generally have to power it on (it doesn't post - no 'bong'), wait a few minutes, then reset it. I initially assumed it was the power supply. But, even after replacing the power supply with a new ATX one, it still exhibits the same behavior.

 

When I originally fixed it, I didn't have a microscope, so one of these days I'm going to tear it open again and double check my re-cap job and that all of the bodge wires are making good connection.

Link to post
Share on other sites
  • 3 weeks later...

@landoGriffin if you still have an adapter board to convert a standard ATX power supply to 840av I'd be happy to purchase. Cheers.

 

Sorry for the slow reply.. I wanted to see if the 840av motherboard actually worked (it does), tested it with a 7200 ... although the powersupply out of the 7200 is totally different shape to the one in the 840av powersupply.. sigh.. otherwise I'd probably just use that one.

 

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...