Jump to content

Classic sad Mac 00000003 00040000 after recap and cleaning


Recommended Posts

  • 68kMLA Supporter

This Classic had Sad Mac error 00000003 00040000. Caps were bad, but the board was in good shape. Replaced the caps all and ran the board through an ultrasonic cleaner. After, it still showed the same error.

 

I replaced and cleaned underneath UH6, but no change. Installing the RAM expansion just changes the type of distortion.

 

It's unclear if the Sad Mac error decoder applies to the Classic. If it does, I'm not sure how to do the math to narrow down which chip(s) are bad. 

 

I saw this post with the same symptom, but it was for an SE, so has a different MLB. I've started to check continuity but so far no problems.

 

 

Assuming this is likely due to a bad RAM, can someone help decipher which chip(s) are failing?

 

 

IoEhH16.jpg

Link to post
Share on other sites

If the error is to be believed it's bit 18 of bank B.

 

For future reference:

 

Example:
$AABBCCDD

AA=8 bit mask for bits 31-24
BB=8 bit mask for bits 23-16
CC=8 bit mask for bits 15-8
DD=8 bit mask for bits 7-0

 

So with your code of 00040000 and with the masks expanded, it looks like this:

31                                                                     0

00000000 00000100 00000000 00000000

 

Maybe a scope or logic probe on the address lines might show you something?

 

Here is the memory page of the schematic:

Screen Shot 2021-02-10 at 7.24.13 PM.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...