Jump to content

128k makes clicking sound from speaker, no video or chime


Recommended Posts

I just picked up a non-working 128k as a project.  When I turn it on there is no chime or video, but there is a repeating clicking sound coming from the speaker.  I'd say about 2 clicks per second.  I'm assuming it's an analog board issue, but I don't know where to start looking.  None of the capacitors are swollen that I can see with a quick look from above, I haven't pulled the analog board out yet to take a closer look.  A reddit user said it could be a HV diode, I haven't taken a look at that yet to see if it is visibly damaged, I'll be doing that tomorrow.  If anyone has ideas for trouble shooting or usual suspects, I'd very much appreciate the input!

 

 

Link to post
Share on other sites
16 hours ago, SamFortun said:

I just picked up a non-working 128k as a project.  When I turn it on there is no chime or video, but there is a repeating clicking sound coming from the speaker.  I'd say about 2 clicks per second.  I'm assuming it's an analog board issue, but I don't know where to start looking.

Are you sure the clicking is coming from the speaker? The power supply will click when there's no load on it.

 

Here's a good starting point: Replacing the Flyback Transformer. Also be sure to turn on your sound and watch the two QuickTime movies which are listed in the Comments at the bottom of that page.

 

If you make a similar movie of your Mac 128K, we can get a lot more information about this problem.

Edited by Dog Cow
Link to post
Share on other sites

Thanks Dog Cow, the original post is mine, I was having trouble retrieving my lost password for this account and it seemed like it wouldn't work, so I created a new account for that post.  Then I ended up being able to reset my password.  Unfortunately I wasn't able to delete the post.

 

Thanks for the link, I haven't had a chance to look at it but will soon.  I took a video of the 128k ticking earlier.  I didn't have the case off at that point, I can take a better video if it would help.  I thought I'd post this in the mean time so you can get an idea of how it sounds.

 

 

https://youtu.be/UtAiRqn07ZU

 
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...