Jump to content

Recommended Posts

Ok I feel like a total noob but I dont understand how the Emu works with my IIc. Never used apple II before so even basics are escaping me, I set up the Emu as a smartport drive (as I saw something about that working for IIc) but not sure how to see files on it. My goal is to get proterm installed and running so that I can BBS on the machine. Any help or direction would be a huge help and much appreciated. 

Link to post
Share on other sites

You've got to name the HD images SMART0, SMART1, etc.  According to the manual on the BMOW site:


Floppy Emu supports Smartport disk images in .PO, .HDV, or .2MG formats. Unlike the other emulation modes, there is no menu for selecting the desired Smartport disk. Floppy Emu automatically uses the disk images named SMART0.*, SMART1.*, SMART2.*, and SMART3.*, where * can be either PO, HDV, or 2MG. If you have fewer than four Smartport disk images, number them beginning with SMART0 and don't use SMART3.

Here is a HD image with ProTERM already on it.  I'll see if I have any others.



Edited by Byte Knight
Link to post
Share on other sites

cool thanks unfortunately i have rom 255 which apparently doesnt work as a smart port disk.  i did find this on bmow blog havent given it a shot yet but fingers crossed..


Andru has devised a method for booting the //c from the Floppy Emu while it’s connected externally and configured in 5.25 inch emulation mode. In other words, it’s a method for booting from Disk 2 – something that’s normally impossible. This is great for the scenario where you want to make a bootable ProDOS floppy, and you’ve got a Floppy Emu, but no real floppies with a bootable DOS. Now it’s possible to boot from the Emu externally, then put a blank floppy in the //c’s internal drive and copy ProDOS to it.

  1. Connect Floppy Emu to the //c’s external disk port, and turn on the computer.
  2. The //c will display a CHECK DISK DRIVE error.
  3. Select ProDOS v1.9 from the Floppy Emu’s disk selection menu.
  4. Press CTRL+RESET on the //c keyboard to get a BASIC prompt
  5. At the ] prompt, type CALL -151 and press RETURN
  6. At the * prompt, press CTRL+E, then press RETURN
  7. You’ll see a line of text like M=00 A=08 X=00 Y=00 P=00 S=B7.
    If the line of text begins with M, then type
    :0 E0 60 1 and press RETURN
    Else if the line of text begins with A, then type
    :E0 60 1 and press RETURN
  8. Type C60BG and press RETURN

The //c will immediately begin booting ProDOS from Drive 2!

Andru developed this method by examining code from Apple //c ROM version 255, which includes this feature natively as PR#7. The above monitor hacking makes it possible to do the same thing on other ROM versions of the Apple //c.


this last part about rom 255 makes me think that PR#7 would work but still a apple ii noob so figuring it out might be tough...



Link to post
Share on other sites

i have the emu set up as a 5.25 drive but when I select PR#7 i get a message that says "no device connected". doing a catalog,d2 will list the files but not sure how to run them (prolly syntax). For example in the prodos v1.9.dsk file that was on the emu i tried "load launcher.system" but I get back "file type mismatch". Is that because some programs absolutely need to be launched from "disk 1"? on other files, oregon trail 1.do for example, if i try to get the catalog i only get a message that says "I/O error". Sorry if these are really easy issues first time using apple II OS.

Link to post
Share on other sites

okay made some progress:


I put prodos 3.1.1 on the sd card > put proterm 2.2 on sd card > turned on iic with emu > run prodos 3.1.1 > it asks for path to file typed "/proterm/proterm.system > it starts to load but then i get a message that says something like "proterm has not been installed on this computer. press esc to continue. press ret to check hardware" > no matter what i press it just seems to lock up 


this is where i am currently stuck.....

Link to post
Share on other sites

should have mentioned i am booting with system utilities v 2.1.1 a disk i have


okay new wrinkle i got applewin to do some testing and if i try to catalog proterm3.1 i can see it just fine in applewin but on my iic it says "i/o error"


note: proterm 2.2 locks up the same way as my iic in applewin

Link to post
Share on other sites

okay I have connected it to the connector on the inside and some programs are working just fine. however proterm 2.2 still says "proterm was not installed on this machine. press return to verify your hardware configuration, or pres esc to continue" but after hitting return it seems just fine (as in it loads and takes me to the next screen havent tested with wimodem yet). proterm 3 is just strange: booting with proterm3(boot) gives the following on screen:

0914-     A=0C X=FF Y=02 P=74 S=D3

then i have a cursor hitting return will just return a EE then return again gets  0400- A0 A0 A0 A0 A0 A0 hitting return again will give a similar but different response. with proterm3(program) selected and rebooting i get:

3F24-    A=BD X=FF Y=02 P=B5 S=C2

then the cursor and it cycles through the same info as the boot disk starting with EE

Link to post
Share on other sites

Okay so I downloaded a different version of ProTerm 3.1 and got it to work with the set up like so:

Emu connected as external disk

boot my floppy of System Utilities > exit that program > set floppy emu to prodos 3.0.1 > run startup,d2 > (in prodos) set path to /pt3/pt3.system > ProTerm 3.1 boots


Now I am having an issue trying to get my modem seen for lack of a better word. So in the ProTerm modem set up I tried the following:


Apple Modem 300 - initialization blank 

Null Modem Driver - initialization blank

Null Modem Driver (RTS/CTS) - initialization blank

Hayes Smart Modem 300 - initialization blank / ATX0 (I think that was what it was, it was the default)


All got me in and the top bar showed 300 baud but when trying to go to the terminal I get a blinking cursor but cant type anything it just flashes.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...