Jump to content

Apple ][ Europlus Rebuild (Project Thread with Images)


Recommended Posts

Preamble: This build thread was first posted on Badcaps.net on the 16th of October, 2013 and subsequently posted to MacTalk and MacRumors' Apple Collectors forum. It documents from start to finish the process of attempting to rescue a 1979 Apple ][ Europlus personal computer. To some here, it'll sound fairly basic, and perhaps a little crudely worded at times. It's a direct, word for word verbatim copy from other forums and hasn't been altered in any form for the 68kMLA.

 

 

Several years ago, I acquired a 1979 Apple II Europlus. It has mostly been a collectors item, stored carefully on a shelf and powered on from time to time to test its circuits. It had been shelved for upwards of 12 months now and was well overdue for a startup.

 

It started up perfectly fine, and I left it to idle while I looked up some documentation for it. About 15 minutes in, the machine made a strange noise which sounded like the Floppy Drive accessing, so I didn't think much of it.

 

A few seconds later, the machine made a POP sound, followed by a CRACK, and a huge amount of thick, acrid smoke started pouring out of the case. A sticky brown liquid started dripping out of the ventilation gaps in the lower casing and on to the desk.

 

With that, the machine was dead. It was 35 years old. Not a bad effort.

 

 

 

Part 1: Diagnosis

 

 

I removed the power supply, an ASTEC AA11042C from an Apple IIe that may have been fitted to the machine as a replacement in the 1980s. The PCB inside the supply is dated 1982, so the supply in itself is around 31 years old. When I lifted the covers... well, I'll let you see for yourself.

 

 

image.jpg

 

 

This large gold-coloured component, an EMI Suppression Capacitor, has cracked around several edges and thrown out a gold-brown coloured fluid. I suspect it's been leaking for some time, because after desoldering the component, I can see that it's pooled below the component in a sticky mess, even making its way through one of the unused holes in the PCB.

 

I cleaned the PSU with a mixture of a Throttle Body cleaner and Alcohol to dissolve and rinse away the sticky mess, going over component legs and traces with a cloth and brush to remove it. I didn't want to leave this stuff anywhere in the PSU as it has the potential to cause further damage if not attended to.

 

 

image.jpgimage.jpgimage.jpg

 

 

Many of the component's markings were destroyed when it failed, but I can see it's a Rifa 0.47uF 250V EMI Suppression Capacitor (X2 Type), used to filter the AC power coming in from the mains.

 

After some research, I can see these are notorious for failing in exactly the manner this one did with old age. This website was the most helpful, and the failure is well documented under the heading Line Suppression Capacitor. As you can see, when they fail, they do so in a rather spectacular manner.

 

 

image.jpgimage.jpg

 

 

Another nearby component looks to also be in the process of failing as a dark patch can be seen underneath it, suggesting it may be leaking and ultimately headed for the same fate.

 

 

image.jpg

 

 

This is one of the least favourite moments for any Apple or even vintage electronics collector. Watching your pride and joy go up in smoke is never a fun experience, but sometimes you can be fortunate. Thankfully this time is one such occasion. After a thorough cleaning and examination of the PCB, it appears that the board itself is in good shape, with no damage to any traces, solder joints or even surrounding components, and these older supplies are easy to service, with no surface mount components and widely spaced connections and tracks.

 

After researching the issue and consulting with some members of the Badcaps Forum, it looks like a replacement of the failed and failing EMI Suppression Capacitors along with a new fuse will bring this old power supply back to life. There are higher quality replacements for the Rifa brand components that aren't as susceptible to failure in this manner, which should aid in improving the reliability of the power supply when it's returned to service.

 

 

 

----------

 

 

 

Part II: Repair

 

 

Swapped out the Rifa 250V 0.47 X and 0.1uF X2 capacitors for brand new Suntan 275V 0.47uF X2 and 0.1uF X2 Metallised Polypropylene capacitors. They're not the best supplier but definitely functional. The existing components had extremely messy solder joints, which were cleaned up, and one of the traces on the underside of the board needed adhering back to the PCB.

 

Overall though, the repair went extremely well.

 

 

IMG_4947.jpgIMG_4965.jpgIMG_4973.jpgIMG_4999.jpg

 

 

Now, this machine smelled like the inside of a International Roast tin. That capacitor residue smelled like coffee, but not in that pleasant way. The smell persisted after replacing the Line Filters in the power supply, so I decided to tear the machine down and service it, and try to find the source of the smell while I was at it.

 

It didn't take long. It made a nice outline of the power supply. Also, check out that perished speaker foam. It was like powder.

 

 

IMG_4980.jpg

 

 

I stripped the machine down to the bottom pan and scrubbed it down with solvents and cleaners. A few seconds in the solvent and the stuff washed off like water. I sprayed the underside of the Logic Board and around the connectors and chip sockets with circuit board cleaner, but it'll take some scrubbing to remove that caked-on dust around the slots and components.

 

I removed the speaker foam and replaced it with a single double-sided adhesive foam disc, stuck to the lower pan. Holds in place with no problems.

 

 

IMG_5008.jpg

 

 

I did take the keyboard apart and give that a clean out as well, but I didn't take any pictures of that process. Needless to say keyboards are my least favourite part of any computer service. After that was done, the machine was reassembled and powered up for testing.

 

 

IMG_5019.jpgIMG_5018.jpg

 

 

Impressively, the video quality has improved quite a bit. No more faint vertical lines on the display, only a perfectly crystal-clear image. You try taking a picture of an awful, low quality Twisted Nematic display though.

 

 

IMG_5017.jpg

 

 

Interestingly, it also looks like the machine has been modified. One chip has been removed, a chip socket has been stacked on top of the existing chip socket, but with two red and black wires coming off it. Then the existing chip has been stacked on top in a piggyback configuration. The two wires travel up to the keyboard connector, with the black connecting to the second pin from the left, and the red connecting to the third pin from the right (looking directly at the connector from the back of the machine, not the front).

 

 

IMG_5010.jpgIMG_5016.jpg

 

 

I have no idea what these do, but the keyboard works fine with them disconnected, so I suspect it's a modification of some sort rather than a fix. [uPDATE: As someone pointed out after this thread was drafted, it may be a a keyboard shift-key mod. http://support.apple.com/kb/TA30700]

 

 

Anyway, with only the memory expansion card fitted, it seems to be running fine and it isn't pushing the PSU too hard. Overall, it's a much happier machine.

 

 

 

----------

 

 

 

Part III: Rebuilding the Disk II

 

 

Satisfied that the PSU is in working condition, I refitted the Disk II controller card and hooked up the 5.25" disk drive. It had no issues with writing a ProDOS disk using ADTPro over the cassette interface, but reading that disk back proved difficult. The drive was also unable to write to my Verbatim and MagMedia brand disks.

 

Not satisfied that I was dealing with a bunch of defective disks, I turned my attention to the drive.

 

This drive lacks any kind of external markings, so after opening it up, I was surprised to see it's in fact a standard Shugart SA390 mechanism. The motors are of rather decent quality, the stepper motor in particular is an American made motor built by North American Philips Controls Corp. in Cheshire, Connecticut.

 

 

IMG_5033.jpgIMG_5031.jpg

 

 

I thought I was dealing with a healthy drive. I may have overestimated the reliability of a drive mechanism now over 30 years old. The tracks were rough and in need of cleaning and polishing, the heads were dirty and the drive belt was slipping around the smaller pulley.

 

First things first - I had to strip it.

 

But I didn't get any photos of this process.

 

I started by removing the collet hub and upper structure that lowers down when the drive door is closed. Then the head assembly and tracks came off. The large brown disc with the track cut into it is press-fitted and had to be hammered off the centre hub, and the stepper motor was removed. The drive belt was removed, and the motor that drives the belt was removed.

 

 

IMG_5026.jpgIMG_5044.jpg

 

 

Everything was sprayed down with solvent and scrubbed clean. Then, into the oil it went! The moving parts were brushed down with a thin coating of Shell Helix 20w50 engine oil, and using a syringe, some oil was injected into both of the electric motors. The top section of the drive was reassembled, including the collet hub, upper structure, tracks, head assembly, spindle motor and the stepper motor. The brown tracking disc was pressed back onto the hub, and the drive was powered up to check movement.

 

Success! Full range of motion in the head assembly.

 

Turning my attention to the belt, I noticed it's a slightly rubbery, interwoven fabric material and is actually quite durable. The belt was soaked in a silicone-based belt dressing then wiped down to remove any excess. The belt was slipped back over the spindle pulley, then over the spindle motor pulley. I pulled the motor out as far as it would go and tightened the screws to tension the belt.

 

No more slipping!

 

 

IMG_5039.jpg

 

 

Afterwards, it was simply a case of starting up the machine, loading across a copy of Apple-Cillin and running a drive speed test. The motor was running a little on the fast side by a few revolutions. A Disk II motor needs to run as close to 300rpm as possible, but the drive works reliably if the RPMs are clocked a few revolutions slower. Running it faster is when issues start to occur. After winding the motor down to around a steady 295-297, all that was needed was to swap in a blank disk, format it, write to it and boot from it.

 

Impressively, this seems to have done the trick. The Verbatim and MagMedia disks are now capable of reading, it can write a copy of ProDOS down with ease and boot from it in just a few seconds flat.

 

I closed up the drive assembly and finished it off with a set of 4 brand new rubber feet.

 

Having this disk drive functioning again makes transferring data to the Apple II significantly easier. Before the drive worked, I would have to boot up over the cassette interface and load data into memory, which does take quite a while. Starting up from the drive takes only a few seconds.

 

 

 

----------

 

 

 

Part IV: Repairing the Joystick

 

 

Now that I have some software on the system, I would like to do something with it. So I hooked up the Joystick, loaded a game and... nothing. The keyboard input worked fine, but attempting to use the paddle buttons had no effect on the Apple II.

 

Here we go again.

 

This Joystick could have been a brand name unit at some point, but its labels have since been peeled away, so I don't know much about it. The buttons have a nice feel to them, and the Joystick assembly has a nice amount of spring tension. It's not perfect, but it's more than adequate for playing games with.

 

Inside is a mess of wires and components, but nothing out of the ordinary for other electronics of the era. I'm almost positive that this Joystick has been worked on before, as it has some telltale signs of damage where a track has been pulled off the board and some wires have been cut and taped back together. One wire was completely loose inside the case, explaining why the buttons wouldn't fire.

 

 

image.jpgimage.jpg

 

 

I took the button out and ran two new wires down the stem of the Joystick, soldering them in place of the old, frayed and cut wiring. One solder track on the PCB was lifted and missing entirely, which was fixed by soldering a small piece of wire in place of the old track. The Green wire was rather in rather good condition, but broken up near the PCB, so I trimmed it back a little and resoldered it.

 

 

image.jpg

 

 

All it needed then was a quick clean up.

 

 

image.jpg

 

 

Best of all, I was able to play a few rounds of Pitstop II with it. Looks like the repairs paid off.

 

Now if only I wasn't so terrible at that game.

 

 

 

----------

 

 

 

Part V: Finale

 

This Apple II was owned by someone that clearly loved it. When it came to me, it was carefully boxed in the original shipping container, with all foam pieces intact. The container itself wasn't as fortunate, stained with water and torn, but they had definitely made an effort to look after it, both in use and in long term storage.

 

Even so, a machine of its age doesn't come away completely clean. The case is textured with many high and low points in the plastic, and over the years dirt accumulates in the surface. I've tried removing this dirt with alcohol and some light dishwashing liquid, but I needed something with a little more kick for this job.

 

After seeing the various marks and patches on the walls and paintwork of the house vanish like magic with this stuff, I decided to give Selley's Sugar Soap a whirl. For reference, I used it diluted in water, and tested on a spare Macintosh Classic case I had around first, where it worked a treat. On to the Apple II!

 

 

IMG_5080.jpg

 

 

I went over the case in concentrated areas at a time, focusing on the top, sides, keyboard surround, base plate and back panel individually. It didn't take much effort, and a microfiber cloth and the Sugar Soap in a spray bottle was all that was needed. Spraying it on to the plastics directly and buffing with the cloth was enough to bring the finish up nicely. For the more difficult areas, such as the keyboard and rear panel, I sprayed it onto the cloth instead of the case.

 

I had to take care while cleaning around the badge and the label on the base of the machine. The badge is in rather good condition, but the dirt had settled into the seam where it meets the case.

 

 

IMG_5097.jpgIMG_5085.jpg

 

 

It wasn't long before the machine was back to looking like a showroom display model. The shade of the plastic is exactly as it was 34 years ago. Not a hint of yellowing anywhere on it. While photos are often forgiving to minor imperfections, I can honestly say that the pictures are a rather accurate reflection of the machine. The plastics are absolutely perfect.

 

 

IMG_5092.jpgIMG_5091.jpg

 

 

The total cost of the repair was $21.70 in tools and components. Additional tools, such as soldering irons, screwdrivers, detergents, oils, microfiber cloths and brushes were already in my possession and haven't been added to the total. It took about 18 hours at 4.5 hours a day for 4 days to complete the build, although it could be completed much sooner if you were to dedicate yourself to it with no distractions.

 

Using ADTPro to transfer data to and from the Apple II via the Cassette Interface is an exercise in patience, but it is a cheap and effective method of transferring data from a MacBook Pro to the Apple II. Using this method, the Apple II now runs ProDOS 1.9.

 

While the Apple II has now been returned to its display cabinet, I'm sure it will still be started up from time to time. It's a valuable piece of computing history, and with the work it has received in this past week, hopefully it will continue to function and be usable to myself and any future owners for quite some time.

 

 

 

Cheers,

~ Mic.

Link to post
Share on other sites

It took a few days for the smell to completely clear out of the room. The machine still smells like it somewhat. What makes matters worse is that the capacitor leaked everywhere, both inside and outside the power supply. After moving the machine following the smokeshow, I found it had made its way out of the case and onto my desk too. Of course, anywhere the fluid ends up, the smell ends up as well.

 

Here's a tip. If you clean this stuff out of the PSU, wear gloves. Five days later, my hands were still stained with the stuff that came out of that cap.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...