Jump to content
kater

Macintosh 12" Monochrome Display M1050 - retrace lines

Recommended Posts

Macintosh 12" Monochrome Display M1050 

Picture faintly visible.

 

Moved thread from here:

 

Replaced caps and tested transistor PH2369 (fine on my cheapo tester).

No other result.

But i never gonna give you up. :)

thanks!

 

 

IMG_1813.jpg

IMG_1814.jpg

IMG_1815.jpg

IMG_1816.jpg

IMG_1817.jpg

IMG_1818.jpg

IMG_1819.jpg

IMG_1820.jpg

IMG_1821.jpg

IMG_1822.jpg

IMG_1823.jpg

Edited by kater

Share this post


Link to post
Share on other sites

Before you fire that thing up, you must reconnect all the grounds back on the CRT board if you want to run it without the shield for troubleshooting. Otherwise you must reinstall and resolder the shield. 

 

From looking at the design, the ground shield is the ground that connects everything together, once removed, it will fail to work right. 

Edited by techknight

Share this post


Link to post
Share on other sites

So it might be the ground shield was not properly soldered back? Seems i wasnt the first one opening it.

As i can't test the IC (with my knowledge), would it make sense to replace it just in case?

(I'd order some anyway for future use) 

Still having a hard time comparing ICs - could you recommend a similar one, preferable available in EU?

LM1201N

 

https://www.mouser.at/

 

thanks for your great support

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×