Jump to content
Sign in to follow this  
VintageAppleKid

Macintosh SE repair help

Recommended Posts

I have recently repaired/restored a Mac SE SuperDrive (well, replaced the motherboard) and i am trying to keep the old motherboard and repair it, the only problem is when i use the old motherboard it gives me a single horizontal white line on the screen, nothing else. I hate to throw away old electronics and i would hate to throw away this motherboard, i know someone of the likes like Retro Recipes could fix this easily but I doubt that'll be a cheap fix, any help?

 

Thanks

Share this post


Link to post
Share on other sites

The single horizontal line issue is typically caused by a failed chip on the analog board as detailed in The Dead Mac Scrolls: https://archive.org/details/mac_The_Dead_Mac_Scrolls_1992/page/n163 and shamada's Repair Mac page: https://web.archive.org/web/20150206072538/http://www.biwa.ne.jp/~shamada/fullmac/repairEng.html#HorizontalLine  Did you replace the analog board (oriented vertically on the side of the Mac,) the logic board, (oriented horizontally on the bottom of the Mac,) or both?  If you replaced the analog board or both boards and the problem went away, then it's probably the TDA1170 chip on the old analog board as described in the links above.  If you did not replace the analog board, but replacing the logic board fixes the problem, it's a much less common issue and is not well documented as to what may be causing it or how to remedy it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×