Jump to content
Sign in to follow this  
mpe

Macintosh Plus keeps tripping RCD

Recommended Posts

I recently acquired a Macintosh Plus (version with the international 220V analog board - as I am in UK).

 

It seems to be working fine. However, there is a strange issue with it.

 

When switched off and connected to a wall socket (the switch on the back is off) it always after a couple of minutes keeps tripping RCD fuse in my house. So it looks like it is leaking current to ground somewhere.

 

It is not the power cable. I tried to visually inspect the analog board, measure input voltage and ground using a multimeter and did not find anything suspicious or obviously broken.

 

Any ideas?

Share this post


Link to post
Share on other sites

probable C33 and C36 these will be cracked after all the years of service and create a shortcut.

 

you can remove the capacitors, you can test the mac without them,

 

 

Share this post


Link to post
Share on other sites

Thanks. C33 and C36. Is that on the original board? The only scheme I found is for the 120V board where this part is actually slightly different. Anyway, I guess these are two small line filter caps (4700 pico farad, Y class) just next to the power inlet. I will try to replace them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×