Jump to content
Sign in to follow this  
MacintoshMan1999

Apple ImageWriter II ribbon not adavncing

Recommended Posts

If it’s genuine Apple it’s common the foam is bad, some aftermarket have this problem too.  Most ribbons are well expired. If you need color ribbions made in 2018, let me know I had a small batch produced. 

Share this post


Link to post
Share on other sites

What i'm saying is that there was a piece of string in the printer running along the width of the printer underneath the carriage that that broke off, I think that has something to do with it. The carriage moves back and forth fine when i activate a self-test, there is text but it eventually starts to fade out and I have to manually advance the ribbon. I think i still have it somewhere, I'll have to look...

 

Thanks, Jack

Share this post


Link to post
Share on other sites

I have the Apple service manual for the imagewiter //.  Its in paper form.  If you want it I can send it to you.  It is too many pages to scan.

Share this post


Link to post
Share on other sites

I have it here scanned it you want...  I have to point out though, this is not my work. I spent ages trying to find an Imagewriter I take apart guide and this is it. It also covers the Imagewriter II of course otherwise I wouldn't link it here. You need to scroll down a bit to find it.

 

Here's an interesting link for those of us who like to take things apart but forget how to put them back together...

http://bitsavers.informatik.uni-stuttgart.de/pdf/apple/service/

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×