Jump to content
ants

Wifi Extension Development Thread

Recommended Posts

On 8/3/2018 at 11:15 PM, Hustletron said:

Is there a specific Ethernet card that you need to use for this to work? Also, have you been able to try this with one of the antenna-less Vonets var411n units? I wouldn’t mind having one or two shipped to you if it meant that we could have this thing work seamlessly someday without an antenna sticking out.

I have grave doubts about feasibility of using an internal antenna in a compact. The grayish/silverish paint on the inside of the case is its RFI shielding. Dunno if it's an effective Faraday cage at WiFi frequencies though. It's meant to corral frequencies in the 8MHz to 50MHz range, could it be transparent when it comes to Wifi frequencies?

 

Has anyone tested the use of a WiFi antenna inside a Compact Mac case? @ants, IIRC you said the Vonets board worked without the antenna hooked up when mounted at the backplane. Was that due to a leaky RFI shielding config or the higher freqs?

 

Edited by Trash80toHP_Mini
typos

Share this post


Link to post
Share on other sites

@Trash80toHP_Mini Interesting point. When I got some peel 'n stick internal antennas for my Basic Beige Sandy Bridge machine, I was worried that the sheet metal case would interfere with the signals. So far, Wifi has been working perfectly (I'm using it as I type, in fact), so my fears were probably without cause.

 

c

Share this post


Link to post
Share on other sites

Curious if anyone has found a router that allows connecting to 5GHz WiFi with the ability to manually configure speed/duplex and disable autonegotiate as is required?  The Vonets device is nifty but 2GHz only (as is the GL-INet OpenWRT AR-300M suggested).  I tried the GL-iNet AR-750, which has dual-band support, but it has two ethernet ports on a virtual switch under eth1, so OpenWRT "ethtool" can't apparently be used to configure manual speed/duplex/autoneg on individual ports (and "swconfig" doesn't seem to let me do it, either).  Next I'm planning to try one of the various OpenWRT-supporting range extenders from Netgear or GL-iNet that only have single ethernet ports, but if anyone's done this already, advice welcome.  Obviously I could set up an additional 2GHz signal but that seems like an inelegant solution ...

 

Share this post


Link to post
Share on other sites
13 hours ago, Crutch said:

"ethtool" can't apparently be used to configure manual speed/duplex/autoneg on individual ports

I had the same problem with my AR-300M - ethtool wouldn't identify eth1 (the LAN port) - but I later discovered that it worked fine for eth0 (the WAN port).

 

So then all I did was swap the LAN & WAN ports using the Luci interface, under Network settings.

Share this post


Link to post
Share on other sites
10 hours ago, ants said:

I had the same problem with my AR-300M - ethtool wouldn't identify eth1 (the LAN port) - but I later discovered that it worked fine for eth0 (the WAN port).

 

So then all I did was swap the LAN & WAN ports using the Luci interface, under Network settings.

 

THAKN YOU @ants ! ... this worked like a charm, including with my AR-750 so I now have perfect 5GHz Wifi access from my SE/30 through a OpenWRT router.  It didn't seem to work at first but after I also did this step https://wiki.openwrt.org/doc/recipes/relayclient it's perfect.  Not sure if that should be necessary, I will try fiddling with it some more and see if I can do without the added bridge interface.

 

 

Share this post


Link to post
Share on other sites

@Crutch awesome! Have you tried out the Wifi extension on your SE/30 yet? I'd love to know if anybody is having success with it.

Share this post


Link to post
Share on other sites

I tried it this week (thanks for writing it) but oddly am unable to figure out the IP to use for to access the OpenWrt router from the SE/30! SE/30 is on the net and works fine (can even browse m.cnn.com with iCab) and can see my main router at 192.168.1.1 from it, but clueless how to find the IP for the OpenWrt router as seen from the SE/30 even though I can ssh into it from my modern iMac over my main WiFi with no problem. Maybe because I had to set up relayd per the link above, could that be “hiding” the GL-iNet router from the LAN somehow? Bit of a networking noob but this seems weird to me. 

Share this post


Link to post
Share on other sites

@Crutch the default gateway IP on the GL-iNet devices is 192.168.8.1, so start by trying that? But if you've bridged your networks, perhaps the device is getting an IP address from your main router.

 

The GL-iNet also provides a hostname that you can use instead of IP address, on the AR-300M the default hostname is gl-ar300m, so I assume it would be gl-ar750 for your device. Try that if the IP address does not work. I believe the hostname can be viewed in Luci, although I don't have the device with me right now to check.

 

Let me know if you get it working, and I'll update the Readme in the MacWifi project with this info thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×