Jump to content
reallyrandy

512k Floppy Drive won't eject

Recommended Posts

I have a 512k that I'm restoring and the floppy reads fine but will not eject. When I manually eject with a paper clip, the disk gets stuck and won't come out. So I cracked the case and removed the drive and carefully removed the disk without damaging it.

When I manually push the eject tab, the drive pops upward but does not propel the disk forward. Not sure if I can (or want to) fix it if I can find a good working one. If one of you guys fixes stuff like this, we could make a deal. I'm assuming it's a 400k drive since it came out of a 512k.

Here's pics:

 

512kDrive1.jpg

512kDrive2.jpg

512kDrive3.jpg

Share this post


Link to post
Share on other sites

I used sadmanonatrain's guide to completely remove the carrier.  It's not hard, 4 screws and a clip.  Then, you can soak it in solvent and work the bits back in forth to completely remove the old grease.  Reassemble and then carefully add a small amount of new grease to the contact points.

 

https://drive.google.com/file/d/0B6j6P7lBWw-BNHQ4dXRYZkFGdzQ/edit

Share this post


Link to post
Share on other sites

Or spray some WD-40 on the contact points (making sure to not get overspray on the drive head). Work it around, wipe down, and put on some new lithium grease. It saves the effort of having to disassemble.

Share this post


Link to post
Share on other sites

I used WD40 on my Macintosh 128K drive with the same problem and it totally fixed it.  However now every-time I run it there is definitely a WD40 smell coming from the drive.  Its been 2 years and it is still there.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×