Jump to content


Photo

Lisa CRT, image stretched vertically far off


  • Please log in to reply
5 replies to this topic

#1 Pitou

Pitou
  • 6502

Posted 08 February 2017 - 02:45 AM

Hello,

 

My Lisa just started to stretch the image vertically too much.

 

I tried adjusting the pots. Recapped the video board. Measured the "Height" pot and it seems fine between 0 ohm and around 96 kohm.

 

It started stretching slowly and finally got this (refer to the attached picture)

 

Could it be related to the power supply?

 

Any idea?

 

Thank you.

 

Pitou!

Attached Thumbnails

  • IMG_2726.JPG


#2 aplmak

aplmak
  • 6502
  • LocationNorth Providence, RI

Posted 08 February 2017 - 03:57 AM

I think it's the video board.. I had a strange similar thing and I recapped the video board all over again and it fixed it.. Somewhere I had a bad cap.. So I'm going to recommend recapping the video board again with all new caps and double check polarity and values... Also in all my Lisa's I've replaced the POTS... you can get them from John on ebay. :)



#3 Pitou

Pitou
  • 6502

Posted 13 February 2017 - 02:02 PM

You were right, it was the video board. Precisely, it was the 7824CT regulator. Resistor R1 was brownish and was running very hot. I replaced the resistor, but that wasn't enough. Replaced the 7824CT and no luck again.

 

Finally I had to replace ceramic caps C32 and C1 along with 7824 (as it was blown again) and R2 just to make sure. C2 and R2 were also replaced before.

 

Now it's running rock steady.

 

Pitou!

Attached Thumbnails

  • IMG_2743.JPG


#4 aplmak

aplmak
  • 6502
  • LocationNorth Providence, RI

Posted 14 February 2017 - 04:04 AM

Congrats!!!! Another working beauty!! 



#5 ScutBoy

ScutBoy
  • 6502
  • LocationNorthfield, MN

Posted 14 February 2017 - 02:20 PM

Congrats!!!! Another working beauty!! 

 

Agreed - always happy to see another of these old girls back up and at 'em!



#6 Pitou

Pitou
  • 6502

Posted 16 February 2017 - 02:24 AM

I have to admit that I'am very happy! :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users