Jump to content
Simon_Carr

SCSI2SD..... Tearing my hair out!

Recommended Posts

I have a Centris 650 that I have been slowly refurbishing over the past few months (yes, that slowly), starting off by recapping all the electrolytics in the PSU, giving the PCB a thorough clean and getting it ready to add 64Mb of RAM, a NUBUS card and, most importantly, replacing the old, broken Quantum HDD with a SCSI2SD. I want to get the system up and running before adding the RAM and NUBUS card.

 

I have been trawling the 68k forums and t'Interweb for an idiots guide (I'm not a complete idiot, but I like to find something that takes me through the process step by step so that I can follow and understand each stage), and the closest I have found is this: http://www.codesrc.com/mediawiki/index.php?title=HFSFromScratch, which although for Linux has been the best I have been able to find. I notice that many other posts also echo that there is a lack of guidance in setting up a SCSI2SD on a Macintosh, so I don't feel alone! So, following this guide as best I can, I have done the following:

 

1: I have used SCSI2SD-util to setup the microSD card, and have changed the vendor details following the guidance elsewhere on this forum:

 

-Set the vendor to the string " SEAGATE" (yes, there is a single space in front of SEAGATE for a total of 8 characters)

-Set the product ID to the string " ST225N" (10 spaces in front for a total of 16 characters)

-Set the revision to the string "1.0 " (with a space after, for a total of 4 characters)

 

2: Using BasiliskII on a G4 eMac I have created an 800MB system 7.5.5 image which is hosted on the microSD card (following these instructions: http://www.emaculation.com/doku.php/basiliskii_osx_setup).

 

3: Prepend the Apple Partition Map.... ???? I have no idea what I should be doing here, I have a Raspberry PI with Debian, but despite downloading the package of files relating to HFDISK I have ground to a complete halt. Can anyone give me some guidance? Is there an easier way of doing this in Terminal or similar? What is the obvious thing I am missing?

 

I have used the patched HD SC app on the Centris (via a Disk Tools floppy), and the computer can detect the SCSI2SD, but wants to initialise the disk (which I am guessing will wipe it), leaving me without my system 7 on board. I've tested the disk using patched HD SC and it has no problems, but I'm assuming that the partition map needs to be updated to become readable.

 

Somebody, please, help me on this one: I am not an engineer or software designer, I just want to use my old Centris once again!

 

Simon

Share this post


Link to post
Share on other sites

Hi,

I don't have a SCSI2CD so maybe will not be of big help here , but if the Centris recognise it , why don't you let it initialise then install a system from the Centris ?

Edited by galgot

Share this post


Link to post
Share on other sites

You're 90% of the way there, but you're doing a few steps out of order.  You'll want to initialize the drive using your Centris.  After it does that, your microSD card will be in the correct HFS format and partitioning, assuming your SD card is 2GBs or smaller.

 

If you're using HDSC setup on a card larger than 2GBs, you'll need to partition it into 2GB chunks.

 

Now take your microSD card to the host machine with the emulator.  Copy the contents of the host image to the SD card, not the image itself.  Your microSD card should now have folders named something like System Folder, Applications, Utilities, Apple Extras, etc.

 

Put the SD card back into your Centris.

 

Should be good to go.

Share this post


Link to post
Share on other sites

Also, you just want to setup, a correct scsi id, with that seagate fake info, and "flash" the card.  Put the card in and then use Apple HD SC 7.3.5 (modded) and initialize, and then go in and create your partition after initialization is done, you should see the drive mount on the desktop.  Then you need to somehow copy the files over.  Network? CD? make a RAM Disk, and install? something to that extent.  If you don't have another drive, get Apple HD SC 7.3.5 (modded on a floppy) or maybe the 7.6 Apple HD SC will just see the drive and you can proceed with that.  I didn't use the Apple HD SC from 7.6, but it might see the drive, (should with the fake Seagate info).

 

Good Luck

Share this post


Link to post
Share on other sites

Okay, a quick update: some progress, but still not quite there...

 

I have initialized and resized/partitioned my SD card (Mac SSD, SCSI drive 0), and it is recognized properly by the Centris. EXCELLENT!

 

What does not seem to be working (yet) is the copying of the contents of my 7.5.3 image from Basilisk onto the SD card. The copying goes fine; I have selected all from the BasiliskII image, copied everything into the Shared/Unix virtual drive, and then in OSX have copied everything from 'Shared' onto my SD card, which is recognized as Mac SSD. So far so good...

 

However, having put the SD card into the SCSI2SD to boot the Centris, I still get the ? disk, so the system wont boot from the SD card. If I use my System Tools floppy to boot, I can see the contents of Mac SSD, and can run software from that drive, but it just won't startup the system from that drive. Am I missing some hidden files or something else straighforwards?

 

So close....

Share this post


Link to post
Share on other sites

Hi,

I think your 7.5.3 system folder is not "blessed". To do that try to remount the SD on your basiliskII or another Mac, go into your 7.5.3 system folder, move the Finder file on your desktop, then put it back in the 7.5.3 system folder as before. You should see the system folder icon changes, and it should be bootable.

Share this post


Link to post
Share on other sites

***** Facepalm moment *****

 

I have just solved the problem, and it was so much easier than I was trying to make it.

 

All I have done is copied my Install System 7.5.3 disk images on to the SD card, powered up the Centris using the DiskTools floppy to start the system up, and I'm currently doing a 'proper' install of the system as if from CD. It is amazing what a break for a chocolate bar and a coffee can do!

 

Thanks for all the advice: it was very much appreciated! In return I promise to write an idiots guide to installing SCSI2SD and post it sometime today on the forum. Browsing through forums and other sites courtesy of Google suggests that I am not alone in being puzzled by this clever piece of kit in terms of how to get it running!

Edited by Simon_Carr

Share this post


Link to post
Share on other sites

 

AND IT WORKS! I FEEL LIKE A DEMIGOD!

 

 

Lol, I know the feeling... Only happens to me while in front of an old Macintosh.

The reason I collect. Better than dope.

Share this post


Link to post
Share on other sites

I'm really pleased, as this was the Mac I wrote my PhD thesis with back in the 1990s, and I have spent a lot of time hunched over it in my past!

 

Everything else has come together really well after getting the SSD sorted: I've checked, cleaned and checked the original floppy and CD drive (complete with disk caddy!), and have upped the RAM from 8mb (how did I ever cope?!) to 86mb, although I think I'll try and max this out while I can still get the right simms brand new from Offtek here in the UK. I have also added an Apple 8/24 video NuBus card; I've given up trying to source the GC version, but was pleasantly surprised with the visual improvement, although I had a few nervous moments when the Centris initially booted up in black and white!

 

Now, all I need to do is work out what to use it for!

 

Happy days....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×