Jump to content

K Trueno

6502
  • Content Count

    91
  • Joined

  • Last visited

Everything posted by K Trueno

  1. Hi, I recently installed a Universal PowerCache in the SE/30 but the "PowerCache" portion doesn't seem to be doing anything. Toggling "PowerMath" seems to increase or decrease performance in Speedometer, but toggling "PowerCache" seems to have no effect (with or without restarts) in between. I've tried empty Control Panel and Extensions and that sort of thing. Using Speedometer I'm getting around 9 for CPU when it should be around 12.. Running the DayStar PowerDemo shows the line "PowerCache external cache is disabled". I can enable it through the menu, but it seems to do nothing, and once I put the Demo App in the background and come back it seems to toggle back to disabled automatically. I'm running System 7.1, SE/30, stock rom. Any thoughts? Or could it be a broken PowerCache? Thanks!
  2. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    If I am interpreting this correctly, does this mean we can run a Turbo 040, MacCon AND a Radius Pivot which wasn't possible before?? Wow! I thought I was at endgame for SE/30 (3 stack), this might have me looking for a Turbo 040...
  3. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Is it possible to buy a PDS flat cable for the DIN-connector? Judging from things it ought to be possible, but it doesn’t look like it’s 1:1. Here is a thread by @Von that shows how he did it, so cool.
  4. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Wow that’s awesome, so not only PowerCache but Turbo 040 too! It does make it feel a lot faster. Without the cache the CPU is always waiting on a 16mhz bus for memory access.
  5. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Summary: if you are using a TwinSpark with a Universal PowerCache, you are not getting full speed compared to the Socketed PowerCache. This is because the cache is not enabled even if it is turned on in the control panel. To enable the enabling of the cache, add a jumper between C11 and C13 on the cache slot of the TwinSpark. This may also apply to the IIsi adaptor and DiimoCache adaptor but we don’t know for sure.
  6. K Trueno

    Micron Xceed w/ Grayscale Adapter Questions

    Congrats! Build pics would be awesome! I am one of a few looking for one as well, but I am learning to be patient!
  7. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Oooo nice! It would be very interesting if there are differences.
  8. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Just a random dude wanting that last 3-4 MIPS out of a 68030 machine along with someone that actually knows what's going on! But yeah I think this is pretty big news for llsi Adaptor/TwinSpark/ProtoCache users. I mean there have been these types of builds described on Gamba's site that would have the same problem. Not everyday you discover something new 20 some years odd on, all thanks to @Bolle . Don't have a pic, but, cheers!!
  9. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Hard to tell from the pic but double check your C13 connection! C14 is +5v and that would cause a short. Otherwise I think you are good!
  10. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Also thank you to @JDW for confirming my suspicions!
  11. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    @Bolle Yup C13 goes no where as far as I can tell. So I tried it! Yaaaaah! Full speed! Fast stars are fast This is a huge discovery for Universal PowerCache users on the SE/30! "Double your computer's speed with a paperclip". That doesn't happen much these days! @ktkm Here is a pic of my "jumper" Yeah its a paperclip right now. I'll take more pics when I do it right this weekend, but there are markings on the PCB to for you to count (C is top row, there is 10 under the tenth pin, then count over connect).
  12. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Nope doesn't seem so (but not home yet to check). How about this way: can I run a wire in the connection hole or outside to connect C13 to GND (say, two holes up to C11) and try?
  13. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    It doesn't look like C13 (I'm guessing that's 13th pin hole on the 3rd row has traces down near the jumpers), so probably not that?
  14. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Good eye! I was just half way drawing lines in those pics and it was rough with the lines in the layers. Can't wait to try to run a wire, after confirming here first if I got it right first of course Yay for fast stars!!!
  15. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Wow @Bolle thanks for looking into it and reproducing! Kinda glad I am not the only one! Hardware is over my head, but if its switchable in software then something must sense an address/instruction/data to "flip a bit". It also seems that PowerDemo is able to "read/sense that bit" - does that stay correct in the Macs where the cache is enabled? I mean, it could also be the Control Panel setting different addresses expecting a different adaptor in an SE/30 - maybe because of Slot $E being used for Video unlike the other Machines? A quote from a certain "jt" gentlemen from a thread on thinkclassic.org. I don't claim to understand much of it. Also, there is an adaptor on eBay right now with some decent pictures, it gives a good view of the 74ACT86 and you can _almost_ make out traces in one of the layers. I'll try to clean it up and put it up here and hopefully that can help.
  16. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Right, so it’s as if the PowerCache setting has no effect and is off in my setup no matter what. It is way under your 13.5 which is what I would expect! I plan to do so now with these benchmarks in hand, I wanted to rule out that I had wrong or misleading benchmarks. I am sure I have loaded the Control Panel right through my PowerMath flipping, and also tested OS 7.5 through a boot floppy, so I am reasonably confident there is a gap. I still do do wonder what other folks with a Universal PowerCache + Adaptor are getting. I also wonder if @trag benched his cacheless 50mhz Accelerator he won a few weeks back
  17. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Thanks @JDW! I ran some new benches, and this is what I see. It really does seem my setup is really under performing yours! Now I am wondering is it just me or other Universal PowerCache + TwinSpark users? Mine-Universal-PowerCache-On-vs-JDW-Socketed-PowerCache-Off Mine-Universal-PowerCache-On-vs-JDW-Socketed-PowerCache-On Mine-PC-On-vs-JDW-PC-Off
  18. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Nope I do not I'm afraid. Great I will try this out once I get home, thanks!
  19. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Appreciate it! Hoping to hear from others as well. Below are some photos:
  20. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Oh its nothing special, its the IIsi Daystar Adaptor. I can still take pictures if you'd like! I have tried that too, it does not affect the Processor benchmark in Speedometer. Thank you for benchmarking in advance! BTW, I tried the Command-Option clicking like you mentioned in the other thread, and it has no effect on my benchmarks! So, while you say it degrades your performance, it makes no changes to mine, which leads me to believe that the cache portion of the PowerCache is not active, instead of the cache being on and the toggle being broken.
  21. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Totally safe.
  22. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Ah yes the unobtainum socketed version (not jealous at all ) How does it bench with the Control Panel loaded at boot time say in these scenarios: PowerCache On, PowerMath On PowerCache Off, PowerMath On PowerCache On, PowerMath Off PowerCache Off, PowerMath Off (I would assume 9 here) I also wonder how PowerDemo behaves for you! I have the blue one (looks like the one in your pictures in shape, but blue). I had not thought about this as being a possible issue! So, I happen to also have an original IIsi version of adaptor and tested it out, and I am getting the same results. But perhaps I am overthinking it, could that last bit just having no FPU, and the PowerDemo thing a red herring (as it happens for @Bolle too?)
  23. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    Thanks JDW, I have tried 1.3, 2.0, and 2.2 to the same effect.
  24. K Trueno

    Daystar Universal PowerCache P33 in SE/30

    That would make sense. Glad its not the hardware Cool thanks for confirming! Maybe it is just how the Universal PowerCache behaves in an SE/30. Because, from @JDW's video comment (Socketed PowerCache - "with Control Panel it goes to 11-13"), and these posts about a DiimoCache (@50mhz): It seems like it should be benching faster. For example, this is my current Benchmark compared with a DiimoCache (@Knez): Better than his original 0.87 yes, but 1.06 vs 2.38 is a big difference. FPU does match his original which makes sense (0.14 ~= 0.16 matches since I don't have the FPU on the card). Pretty interesting! Funny trying to squeeze that last bit of performance out of a 16/50mhz machine
×