• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

SE FDHD ejects boot disks, won't acknowledge SCSI2SD

Hi all. I'm new here.

I have a Mac SE FDHD that used to boot from the internal HDD. Sometimes. It was getting flaky. So I purchased a SCSI2SD v5.1 and connected it and applied some disk images from savagetaylor's blog using dd to no avail. The SCSI2SD lights up, is being fed power (have tried MicroUSB, Molex -> Floppy, and just the SCSI 50pinF cable), but the Mac acts like it's not there. Just sits at the image of a floppy with a blinking "?" Using the same image works for Basilisk II so I know it's a good image.

I tried the original HDD and can't get that to boot now either. It was already flaky.

So I tried some 1.44mb boot floppies instead. I tried 3 different images. The mechanism seems solid, the disk goes in, reads for a second, then I get an image of a disk with an "X" on it and the disk ejects itself. It says FDHD on the case of the Mac so I assume I am using the right kind of floppies..

The only thing I can think of is that maybe this has something to do with the internal battery? I have never replaced it. Or maybe the SCSI ribbon is bad? But this should haven nothing to do with the floppy not working either. Other than these I have no idea. Could use advice.


Well-known member
First of all, welcome here to the forum! I hope we all can be of help to you.

What machine are you using to make these images/floppies? How have you configured the SCSI2SD? Has the machine had its logic board/analog board capacitors replaced? Have you ever serviced the floppy drive? Do you have a known-good external floppy drive you can use to test these disks (or another Mac)? Many things to test/troubleshoot.

The internal battery would not cause this, but I would get that thing out of there ASAP if it is old before it explodes.
Using a Windows machine with a usb floppy drive.

SCSI2SD was set with default settings mostly, single SCSI drive with ID 0. Tried all of the recommendations here too (Apple quirks mode, Set the vendor to the string “QUANTUM”, Set the product ID to the string “FIREBALLX”, where X is a number between 1 and 9. Set the revision to the string “1.0 “)

I do not think the caps have ever been replaced. I looked into this and spoke to a few professionals and they said it’s only super necessary on the SE30.

I have not serviced the floppy.

I have a candyshell G3 iMac running OS9 and could attach an external floppy to that. Is that even useful? I don’t have another Mac with a built in floppy.

Planning on getting a new SCSI ribbon ASAP and also trying to clean the floppy drive a bit. I have also ordered official Apple 800kb 6.08 boot disks from eBay so I know my Img files aren’t the problems. I don’t have a lot of confidence these will help :(

Are there some keyboard keys I should hold down while turning on the machine to try to force a different boot mode?


Well-known member
Did you see this thread?
Or this website.

Perhaps you can try some configurations for your SCSI2SD.
The capacitors in a SE are not so a huge problem as in a SE/30.
Floppy drives should be cleaned. There are tutorial at youtube.
I think that you have a problem with the configuration of the SCSI2SD.
My next step would be to produce a new boot disk and to try booting with the floppy drive.
Sometimes there are 800k drives in SEs, even if they were a SEHD. Or the logic board was changed and can not read 1.4 MB disks. But 800k disks are difficult to produce. You need another compact mac for this.
If the mac boots you can try software like lido to check if the scsi2sd is seen by the mac.


Well-known member
The capacitors in a SE are not so a huge problem as in a SE/30.
To clarify, these are the logic board capacitors. The Macintosh SE and SE/30 share essentially the same analog board and PSU, both with leaky capacitors that must be replaced.

I have a candyshell G3 iMac running OS9 and could attach an external floppy to that. Is that even useful? I don’t have another Mac with a built in floppy.
I think that this could be a useful thing to try out. Mac OS9 is usually a lot more tolerant of Macintosh-related files than Windows is. If you can connect your iMac directly to the internet, System 6.0.8 floppy images can be downloaded here: https://obsolete.macfixer.com/vintage-software/

I have not serviced the floppy.
This would be the first thing I recommend that you try to do. Dirt on the floppy drive head can sometimes prevent it from reading disks. The original grease is usually completely dry, and this is really hard on the mechanism and gears.


Well-known member
Something may be happening to the images when they are made with the PC. Now, I cannot speak from experience since I have only ever had Macs. I would agree, trying from the iMac would be helpful, especially if it also has OS 8 or 9 running on it. This really is a chicken-and-egg thing, as we don't know if the floppy drive is good, and we don't know if the disk works to be able to start the machine since you have no other machine to test it on. There is something called "blessing" the System Folder on a disk, meaning that the machine recognizes the folder as a legitimate system to start from. That usually happens when you place the needed system files in the System Folder, close it, and then you see the small Mac icon on the System Folder. Then it should work. However, you can't check that unless the machine is already up and running or you have another old Mac to test it on.

As for your question, original, non-intel or ARM based Macs do not have command-line type underpinnings, there is no such thing as a boot menu to change what drive to start from. However, they have a built-in boot order. This order is: 1 - Internal Floppy Drive, 2 - External Floppy Drive, 3 - SCSI chain, starting from lowest to highest address. The Mac automatically checks in that order. That way, if you have an HD, but put in a floppy with a system folder, the floppy will automatically supersede the SCSI chain and the machine will start from it.

So, there are a few things to sort out for sure. I agree with suggestions as above. What I would try and do is this: 1 - Get that USB floppy drive hooked to your iMac. Download known-good floppy system images (the links above should be good), and use Disk Copy on your iMac to make the image into a floppy (I assume you have OS 8 or 9 on there?). Once you have done that, try that floppy. 2 - If that doesn't work, then move on to floppy service. That video, or one I have, should help. If the disk does work, then I would get a copy of Apple HD SC Setup (Patched) to work on any SCSI drive:

Patched HD SC Setup

Run that on the SE with the SCSI2SD installed. If it is able to see the SCSI2SD, use it to format the SD card (another question: how large of a partition did you set in the SCSI2SD Util preferences? It can't be >2 GB, and I'd even say to make it a little smaller. This must be because of OS limitations). If that format works, quit HD SC Setup, and you should see an HD icon on the desktop. If you do, copy the system from the floppy onto the HD, and then it should start from the SCSI2SD just fine. If you are unable to format the SCSI2SD because of an error, or HD SC Setup cannot see it, then we have more SCSI2SD work to do. I know this is not the "format the SD with an image" method, but I have always had more success letting the Mac you are going to use the SCSI2SD on format the SD card, rather than trying to impose something on it from another machine.

Lastly, no matter what happens, you are correct, the SE logic board doesn't need immediate recapping...but the analog board and PSU do.
Thank you all for the quick responses.

- I will take the G3 out of storage and try to make some disks with that instead using DiskCopy. I have gotten it on the internet but it’s not an easy affair. I will use a modern Macbook Pro to format a flash drive and copy disk image files to the G3 in that manner, avoiding Windows altogether.
- Will try to clean the FDHD floppy drive today. I have one of those floppy cleaners in a drawer somewhere but will watch the above video first and see what is recommended
- I have tried several SCSI2SD configurations but will try some more. I have thoroughly scoured the savagetaylor site dochilli mentioned but will also look at that forum link.
- Also I have an 800kb boot disk coming in a week from eBay and will try that when it arrives. I am feeling that perhaps this thing simply does not read 1.44 mb disks… found an interesting post online that I will cross reference to see if perhaps my device isn’t capable
- I simply cannot replace the capacitors today. If I can get the machine working, it’s a project for another week. I have to order parts etc. I am somewhat comfortable doing this myself - I’m handy with a soldering iron and it’s the sort of thing I have done with several old synthesizers. But the CRT gives me pause. I have heard scary stories necessitating discharging it’s caps.

- Does anyone know which logic board models are capable of reading 1.44mb disks and which are not? Same goes for the floppy drive itself. This way I can see this when I am inside the case and potentially stop futzing with making my own disks.
- Can anyone recommend a replacement capacitor kit or something? (I will also search this forum I’m sure you have discussed it before)
- Do I absolutely need 4mb RAM to run System 7? I assumed YES which is why I’ve been sticking with 6.0.8. I only have 1mb. With some new chips arriving in a week or two from eBay.

Will report back soon. Thanks again all.
An update for you all!

I cleaned the floppy drive a little bit but it was already in good shape.

I used a 800kb 6.0.8 System Tools diskette (from eBay) and got a Happy Mac right away. Booted. Swapped to my own 1.44mb System Tools disk and got a “this disk has errors would you like to repair?” message. After repairing, this diskette now works too! I guess Windows messed with my disk a little too much.

Then I reattached the SCSI2SD and launched the HD SC Setup 7.3.5 (Patched) and successfully initialized the SD card as a hard drive!!! Wooo!!!

I don’t have Utilities 1 & 2, Printing diskettes but will try to make them (and probably “repair them”) and get a complete 6.0.8 install on the HD.

So happy. Thanks for all your help folks

So I think I figured out what the issue with my Windows-created boot disks was. There are both 800k 6.0.8 System Tools images (set of 4) and 1.44mb images (set of 2). I think was trying to write the 800k images to 1.44mb disks. I just tried to create new diskettes from the 1.44mb images and it worked on the first try! Seems so obvious now…


One thing I wanted to mention about the SCSI2SD disk images you created based on images from savagetaylor - are you aware of the difference between "volume" images and "disk" images? You seem pretty clued up so I'm sure you probably do but just checking you are using disk images.
I assume you’re referring to the 2GB “volume” image provided by savagetaylor vs the 6.0.8 “disk” images (which are 800kb or 1.44mb a piece). Yes I understand the difference between those.


Sorry for the delay in replying - looks like I didn't have email notifications set up for forum replies.

I'm talking about the hard drive images for SCSI2SD not floppy images. It describes them here ( https://www.savagetaylor.com/downloads/downloads-macintosh/ ) in section 2.1 and 2.2 but essentially a drive image is the same as a volume image but is prefixed with the boot driver and partition information which takes up the first 48KB. I've not tried booting via SCSI2SD with a volume image but I believe it won't work. It'd be really easy to get these mixed up and since they are both almost the same 2GB size, it'd be hard to spot the difference later.


Well-known member
To answer an earlier question, you will definitely want 4MB of RAM for System 7, though it will technically run with a minimum of 2MB I think. If sticking with 1MB of RAM, 6.0.8 is definitely the way to go.