• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Powerbook 180 No Boot

macuserman

Well-known member
49A80A9A-011F-45E8-9E22-4D1B70F2E68A.jpeg

Alright so here's the drive that was in it, I really have nothing to lose attempting to fix it so I'm hoping someone can give me some tips here. I Do hear it making noises like it's trying to read then at the end it started "clicking" so not sure if the drive is hooked up the computer just tries forever to read it. I did find I had an OS 8 floppy handy and I put that in and was able to get the happy mac before being told it was incompatible, so I really think a drive will cure this laptop. Super excited to see it actually get to the desktop, I'm not even sure how much memory it has in it.
 

macuserman

Well-known member
Also I was looking at alternatives for the hardrive and it's pretty confusing out there. About 100 different versions there is bluescsi there is scsi2sd and then there is v5 and v5.5 etc etc. How the hey do you guys make sense of it and decide what to get?

I am less concerned about the financial side of this and more interested in ease of use for whatever that's worth. I don't care about fancy features and I'd love to not have to spend a few hours understanding how to configure and use whatever I bought. As close to buy it and just put it in as possible is ideal.
 

desertrout

Well-known member
That drive is 120MB - curious to see what might be the problem inside. Not sure the IBM drives suffer from sticky bumpers... more of a Conner / Quantum thing. I guess we'll see!

Agree that the choices for modern HDD options are plentiful - a good problem to have. In terms of ease - in my experience - BlueSCSI is the simplest to set up and use. Probably the best route (easiest, quickest) is to purchase one of @androda 's built PB boards https://androda.work/product/powerbook-bluescsi-version-4-f1-tba-pb-v4/

I have a BlueSCSI in my Portable and it's great, and I have two PB versions (not androda's) on my bench waiting for blue pills to arrive. Happy to endorse the project.
 

sutekh

Well-known member
Agree that the choices for modern HDD options are plentiful - a good problem to have. In terms of ease - in my experience - BlueSCSI is the simplest to set up and use. Probably the best route (easiest, quickest) is to purchase one of @androda 's built PB boards https://androda.work/product/powerbook-bluescsi-version-4-f1-tba-pb-v4/

I have a BlueSCSI in my Portable and it's great, and I have two PB versions (not androda's) on my bench waiting for blue pills to arrive. Happy to endorse the project.

Agree it's a great problem to have! Just be conscious of the performance implications @macuserman. I have SCSI2SDs in my 180s vs. BlueSCSI because the performance delta between the two is noticeable and measurable on a 68030. BlueSCSI is an awesome project with great support and ease of use though!
 

desertrout

Well-known member
Agree it's a great problem to have! Just be conscious of the performance implications @macuserman. I have SCSI2SDs in my 180s vs. BlueSCSI because the performance delta between the two is noticeable and measurable on a 68030. BlueSCSI is an awesome project with great support and ease of use though!
Oh? Interesting... I thought someone had run the benchmarks and the delta was minuscule. Well, I suppose that's a typical trade off... ease-of-use (and cost) vs. performance. (Though, I don't think the SCSI2SD is really that difficult to use... a matter of degrees). Good to know!
 

macuserman

Well-known member
Agree it's a great problem to have! Just be conscious of the performance implications @macuserman. I have SCSI2SDs in my 180s vs. BlueSCSI because the performance delta between the two is noticeable and measurable on a 68030. BlueSCSI is an awesome project with great support and ease of use though!
Ahh! Ok that's good to know! I haven't pulled the trigger on it yet to many projects going right now, so far I just got the 180 and now it's sitting on the shelf. It's not really a machine that I wanted or needed but I just like the challenge of reviving the old tech. So now that it's mostly fixed and the mystery is gone.... Anyhow we'll see what happens to it, I'm hesitant to drop the money on an expensive drive solution since I don't think it will improve the value and I think it may be finding a new home when I am sufficiently satisfied with it. Still shopping around a little maybe I'll stumble across a nice used scsi drive I really do love the noise they make.
 

desertrout

Well-known member
Still shopping around a little maybe I'll stumble across a nice used scsi drive I really do love the noise they make.
They do pop up on eBay for cheap once in a blue moon... I agree with you there about their noises (and I prefer to keep things stock when possible). Did you open up the drive to see what's up?
 

macuserman

Well-known member
They do pop up on eBay for cheap once in a blue moon... I agree with you there about their noises (and I prefer to keep things stock when possible). Did you open up the drive to see what's up?
I did crack it open but nothing in there jumps out I’ll confess though I have no idea what I’m looking at.7667D75E-E5D9-4A16-BA73-8AF1626A7AF2.jpeg
 

macuserman

Well-known member
Alright so my parts board from eBay came and I was very excited to get a good connector for the battery. I figured first I’d just try the new board and see if it worked nope not that easy screen just shows garbage and I didn’t get any boot chime.
So I switched back to the original board and verified it still booted to the flashing folder. It did so first step is to remove the old broken connector.
59B7B394-B36F-42D0-B020-9627143F542A.jpeg

Then I grabbed the connector off the donor board.
F451224B-3EDF-461D-A342-B39AC86274DA.jpeg
716F8192-A3AB-4EC8-88CF-9910B7466868.jpeg
And soldered it onto my old board.

17DBC5F2-F63C-4B59-8298-CFB5D9EE8ED1.jpeg
Beautiful that’s how it should look!
Then decided to epoxy a few broken standoffs while I was in there.
4879E3D1-7637-4D7A-B77B-9267104CC79B.jpeg
A1F11B92-920F-48A7-9B44-B8DF1F7C55CD.jpeg
Buttoned it all back up and!!!
7100E6D3-B863-4FBA-9EE9-FA3AB4B62D9A.jpeg
Now I have no boot chime and garbage on the screen. :(
 

macuserman

Well-known member
Ugh so frustrating! So at this point I have tried switching memory, floppy disk drives unplugging the drive cable, switching the host video board things whatever it's called that the top half plugs into etc etc multiple times and all I get is the screen lights up and displays garbage. I'm lost.... :( The only thing I can think of is maybe I've stressed the video connector cable that goes to the top half one to many times but I just don't know. Any ideas? I've tried everything I can think of.
 

3lectr1cPPC

Well-known member
Still no boot chime after swapping the terminals? If that's the case then I would think it would be more than just the video connector cable. That cable that connects the 2 halves also controls the speaker, keyboard, trackball, and all top case parts so if it's bad then that could explain the lack of a boot chime. Then again, I can't imagine how that would end up breaking. The cable in my 170 looked pretty robust.

I hope you can end up fixing it, I mean, you've already put this much work into it. Hopefully someone more knowledgeable can chime in here. Don't give up!
 

macuserman

Well-known member
Still no boot chime after swapping the terminals? If that's the case then I would think it would be more than just the video connector cable. That cable that connects the 2 halves also controls the speaker, keyboard, trackball, and all top case parts so if it's bad then that could explain the lack of a boot chime. Then again, I can't imagine how that would end up breaking. The cable in my 170 looked pretty robust.

I hope you can end up fixing it, I mean, you've already put this much work into it. Hopefully someone more knowledgeable can chime in here. Don't give up!
It's frustrating because right before this when I had a working powerbook that only needed a hardrive. Now because of my greed and strife for perfection and desire to make it able to have a battery again I have a broken one. Ugh, probably just need to take a step back from it for a bit and take a look again with fresh eyes. I suspect the cable because I think everything else on it is good and that cable is so stiff and hard to attach I may have just flexed it one to many times in my 12 dozen opening and closings of this case trying to fix it.

Just can't leave good enough alone, I really wanted this thing to be 100 percent.
 

macuserman

Well-known member
Unfortunately it's a bit bittersweet, I ended up having to use the parts motherboard with the original video board, and the parts units memory to get this to happen. However, now my good battery connector is on the original motherboard which now apparently no longer works. I must have damaged it somehow when I was working on it but I dont' know what I did. I'll either need to swap the battery connector back over, or troubleshoot the original board. Ugh :(

Anyhow good news is that from the parts bin from ebay I was able to scavenge the hardrive so it is finally able to boot fully for the first time, as well as the memory and apparently the motherboard, oh it also came with the modem which I didn't have before not that it's terribly useful but at least it's complete. Kinda made me wonder if it was possible to swap out that modem board for an ethernet board if one were ever made for it. Anyhow a bit of a mixed bag here but it's not hopeless just yet.

BTW does anyone know if there is a place that will rebuild these batteries? If I ever do finally get a functional motherboard with a good battery connector on it....?
 

3lectr1cPPC

Well-known member
I remember seeing a thread that showed how to 3D print a new shell and fit contacts to use standard rechargeable AAs, the only compromise being that you had to charge externally. It seems it may have been lost in the crash though, because I can’t find it anymore. I think the print template is on thingiverse or some site like that so you can probably print a shell, fit terminals, and make it work.
 
I haven't seen or heard of an internal ethernet module yet, only a poopy old modem card. As for the hard drives, I have had good luck moving the arm back and forth a bit to free it from being glued to one of the old rubber bumpers. Longer term you'd cover the rubber bumper in tape.

For all my powerbooks that need a new drive I have been using the BlueSCSI powerbook edition from Tech by Androda. Seek times are excellent.

I only have one functional battery for my 180. It ended up being an aftermarket one that came with the laptop. I have not re-stuffed or cracked open any original apple batteries yet. Maybe one day!
 

beachycove

Well-known member
For Ethernet on the PB180, you are limited to SCSI to Ethernet devices or to one of the LocalTalk to Ethernet adapters (“Etherwave” is one name that springs to mind: https://archive.org/details/farallon-etherwave-mac-powerbook-adapter-manual-guide-book/mode/2up ). Throughput of the former was comparable to Ethernet speeds of the day, and throughput of the latter was better than LocalTalk by a factor of 2x or 3x or some such, but slower than Ethernet. You could also opt for a software bridge running on a different machine as well.

If I were you with that machine, I’d let it run for an hour or so to see whether there is any screen tunnelling before spending much more money….
 
Top