• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Old Seagate Hard Drives


Well-known member
My Quadra 650 has suddenly decided that it doesn't like SCSI replacement devices like BlueSCSI any more (even ones that my SE/30 will use quite happily). Whilst this could be a sign of an impending failure, it should be said that the 'Like BlueSCSI' part of the previous sentence is doing some seriously heavy lifting because a) I haven't actually tried a BlueSCSI yet (I'll do that tonight) and b) what I have tried is seriously shonky so the real surprise is that the SE/30 doesn't have a problem with it (SATA SSD in SATA to IDE adaptor, which is on a IDE to SCSI bridge). The Quadra is quite happy with a real SCSI hard drive though (and I found some software not on the Mac Garden on that drive, so expect an upload soon!)

It got me fiddling around with some other hard drives that I had lying around though, none of which worked, but I wondered if they could be persuaded to work (I'd be interested to see what's on them - files from my long gone past). I'm fairly sure they all worked when I originally pulled them, but they weren't necessarily in a Mac originally and they weren't necessarily internal either.

For my experiment, I set them all to ID 0 - and I must admit that I was flummoxed by the (overly complicated) termination settings on these old SCSI drives. They aren't just a case of to terminate or not to terminate.

I'll list the drives, and problems I saw. I was scanning the bus with Lido.
  • Seagate Hawk ST15230N - The drive spins, no unusual noises or clicking, Lido sees it on ID 0 and reports 'Phase Error'. Is the drive dead, or is it a jumper setting that I've gotten wrong?
  • Seagate Hawk ST11200N - The drive spins, no unusual noises or clicking, but the Mac crashes on boot with 0000000f 00000003 - which is apparently a driver error. Some have suggested starting the computer and then plugging the drive in after start up (not a chance - I'm not risking my old computer!) or fiddling with the jumpers (but what to?). A slightly safer option that I'm considering is putting the drive in an external enclosure, plugging it in to one of my LCIIIs (on the basis that since I have two I'll be a little less upset if something goes wrong), starting the Mac up and then turning on the power to the external enclosure. That should be a safe option. Thoughts?
  • Seagate Barracuda ST15150N - The drive spins (it's very shrill), but keeps spinning down every few minutes. No clicking noises. Lido never finishes scanning the bus (watch cursor never goes away). I suspect that this drive is beyond redemption, but could this be a jumper setting issue?
So - any thoughts? On eBay as 'untested'? 😉 (I'm not serious about that - that's just something that really annoys me. If they're irredeemable then they'll be broken up for scrap metal - there's quite a chunk to be recycled there!)


Well-known member
I have revived several hard drives, but to be honest this an hit or miss game.

I have used several tricks, including plugging the drive after the boot sequence, no risk here… or using an external enclosure.

Most issues are related to stiction or bad boards.

Nothing to lose really, you can have the top cover removed to have a look inside while the drive is hooked.

Also, have been lucky with some drives, swapping boards, but your drives probably don’t have the same setup.


Well-known member
Do you know what the correct termination settings should be for a Mac? Beyond just “terminate the last device in the chain”. These drives have several termination blocks covering what gets terminated and when. Even by SCSI standards it’s a mess!


Well-known member
Yes, the rule is to termínate the last device.

So, both ends should be terminated.
By default the logic board is already done, so connecting any device to the SCSI chain should be set…providing a termination.

The ID for the internal drive is 0, just a rule, can be anything from 0 to 6 (ID 7 is for the computer itself)

Anything connected on the back port can be anything from ID 1 to 6, but commonly 5 or 6.

Concerning your jumpers, cannot help, try to find the settings for each hard drive online, probably still available.

In my opinion, only one jumper is provided for termination, the others for SCSI ID.


Well-known member
Yup. I’ve checked those manuals, and I know the rules for when and where to terminate for the Mac. It’s the additional settings for termination that those drives support which confuse the hell out of me!


New member
I think you should be able to get Seagate Hawk ST15230N going if it's a phase error. Maybe not... Who knows!
If LIDO sees it as ID0 then that means J5 and J6 jumpers are blank, which is good for this test.

Do the jumpers on that drive look like below? Do you have any of these jumpers missing?
Green circles are default populated jumpers. Red circle is an option.

Green text are default settings from factory ST15230N

J5 and J6 = BLANK

TE - Enable Terminators = ON ( According to the manual, this should be populated already as it is default )
ME - Enable Motor Start = ON ( Default is populated as well... Of course )

TP - Term Power From SCSI Bus = ON ( Mac scsi bus should be able to provide term power )
TP - Term Power From Drive = ON ( Default setting for this drive which should work as well )
For Term power, I am unsure if you can set it to TP from drive while the mac bus provides the power as well.
I'm pretty sure it's ok! But maybe someone else can chime in. But this is easy to test on you side by trying either or options.

Keep the rest blank.

If those J2 pins are like my Seagate drive and you don't have spare jumpers... Then uh... It's time to get creative!
I don't even know what standards those are. And they are fragile. Don't ask me how I know this.

Try this out and let us know.
Or tell us you've already tried this and admit the fact that it's time to go SCSI drive skeet shooting 🥳

Apply the same logic for the other drives.



Well-known member
Sorry to bump - but I think I may have found a clue.

I was messing with an IBM DSAS-3360 drive which was displaying the same symptoms as the ST15230N - Phase Error. When I popped a jumper on to disable TI Negotiation, it all burst into life. Which makes me wonder - can I do the same on the Seagate Drive? What would be that setting? Or is it just incompatible with my old LCIII?