• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Anyone have a Focus EtherLAN SC-T?

snuci

Well-known member
I scooped up two of these on eBay but they don't have power supplies.  Does anyone have one or know where to find a manual so I can check the power requirements?  It has a center male pin in the round power plug.  Is it center positive or negative?

Any help is much appreciated.

 

lopaka1998

Active member
If Focus is the name of the company and they're out of business, maybe you could find an archived version of their website at www.archive.org and hopefully find something?

Alternatively, you really just have to use common sense and logic and just "figure it out".  Does one of the pins connecting to the power jack go to ground?  Can you trace one side using a dmm on diode mode to see if maybe one pin goes to the plus side of an electrolytic cap?  If so that's the positive side, etc...

As for voltage, who knows.  Check for the chip numbers on the board and look up their datasheet.  Usually voltages in are mentioned, and it might give you a clue.

It's time you did some detective work.  Good luck.

 

snuci

Well-known member
Thanks for the tips.

I did look at the Wayback machine and found their website and mention of the card but there was no documentation posted.  There was a link to their drivers but the link pointed to an FTP site that doesn't work (and Wayback doesn't archive).  I think I found the drivers in Mac Driver Museum here: http://www.3rz.org/mirrors/macdrivermuseum/network.shtml.

I cracked it open last night and the two wire go to two locations marked "AC IN".  I will certainly need to do some more detective work because if it's AC, the universal wall-wart I have is no good.

I'll try to post a pic later tonight if nobody has the answer.

Thanks.

 
Last edited by a moderator:

snuci

Well-known member
Hi Charlieman,

I can't see your reply but I did get it via email (probably an issue because of the the downtime).

You stated:

I have one, complete in box with the original power supply (UK voltage).

The EtherLan unit is W 140mm H 40mm L 185mm, black, with utp and AUI ports on the back.

The power supply is rated 12V 19.2VA. Mutlimeter test without load is centre negative.

--

Focus Enhancements acquired two designs from Nuovotech (Nuovolink SC and SC-T) along with some other networking products. The design originally came from Compatible Systems (who sold only the Ether+ SCSI with AUI). The power supplies may not be the same for these.

Is the 12V AC or DC?

Thanks for the reply.

 

Charlieman

Well-known member
12V DC, centre negative. I tested with the probes in both directions and it definitely appeared as DC.

 

snuci

Well-known member
Thanks Charlieman,

I appreciate it but mine appears to be center positive.  The center lead goes to an internal fuse that, I'm pretty sure, is positive.  It's also a black wire as opposed to a blue one on mine.

Here's a picture of my board:

Focus EtherLan SC-T board.jpg

 

Charlieman

Well-known member
You're right, snuci. Under load, the power supply measures ~15V AC -- over the back of the supply connector.

My board appears to be a little older than yours but the layout is the same. The chip (EPROM?) labelled SC/SCT on yours is labelled Focus on mine. I also have Compatibility Systems Ether+ silkscreened on the board adjacent to the big blue capacitor.

 

snuci

Well-known member
Thanks for the reply, Charlieman.

So the power supply has the 12V (AC) 19.2 VA markings on it?  I was pretty surprised when these didn't have any sort of label on them to indicate the power consumption so I figured they would be on the power supply.

Thanks.

 

Iesca

Well-known member
Did we ever confirm the details of the PSU for sure? I just received one myself and it is missing its brick as well.
 

Iesca

Well-known member
I did a quick test with a selectable-voltage power adapter. I set it to center-positive and 4.5 volts (supports up to 0.6 amps). The front panel LEDs lit up, but I'm of course wary of increasing the voltage any higher without confirmation...
PXL_20220714_050629665.jpg
 
Last edited:

Chopsticks

Well-known member
obviously only going on the pictures, its most likely AC, it would make sense due to the full bridge rectified located at D3 (to the left of that large 2200uF cap). however while I could be be wrong id more expect it to be 9v AC input.
you see 12v AC to DC conversion usually provides around 15v DC after the bridge rectifier. considering the 5v DC CPU, logic, ASIC's etc used dropping 15vdc to 5dc not only seems like a major waste it would also get very hot and I see no large heatsinks there to dissipate the amount on waster thermal energy produced. obviously if

id suggest trying with 9v AC before trying 12v AC wall power supplies. also its quite likely you could just feed in a dc voltage regardless due to that bridge rectifier on there, usually 9/12v dc @ 1A would suffice there.

also 4.5v is going to be just to low voltage to work. you would need 5v dc if connected directly to the IC's.
easy solution would be to measure the power and ground on the eprom while feeding voltage into the input jack.

lastly the Focus EtherLan SC-T is basically a Focus rebranded Nuvotech NuvoLink SC (focus bought Nuvolink). if you need more Information perhaps try contacting @saybur as he reverser engineered the whole device so he should know a great deal more about it all.

not sure how helpful what I said above will be but maybe it'll help point you in the right direction
 

Iesca

Well-known member
Thank you for your detailed response, @Chopsticks. Although I am decent with a soldering iron, my knowledge of just how these circuits function is low. I do know though that too high a voltage can easily fry delicate components. I suspected that the 4.5VAC that I was sending was indeed probably too low, but figured it was at least low enough as a general test of fitness for the device without causing any damage. Indeed, as you see in my second photo, it was enough to power the LEDs, but I did not test it for overall functionality. I will probably try it again at 9VAC, unless @saybur or someone else comes forward with different guidance.
 

Chopsticks

Well-known member
no worries, see how you go trying 9v AC if that is unsuccessful try 12vAC, otherwise down the track if you can't get ahold of the required AC adaptor if you post a picture of the back of the pcb, myself or someone else can probably trace out the power traces from the power jack and figure out exactly what's going on.
on further inspection though it looks like there is a dc-dc buck/boost converter (3406API) at U16 that's providing the main power supply for the rest of the board, it have a max input voltage of 40v DC so I a 9/12v AC adaptor is definitely going to be fine to use.
 

Chopsticks

Well-known member
I just had a look at that picture. what I said in my last post is still correct with regards to 9/12v AC. either will be fine to try.

also here's the latest drivers for this SCSI ethernet adaptor its a zip'd disccopy image
Im not sure what system version you plan to run this on 6/7 etc but ive run this on upto system 7.5.5 if memory serves correct...
 

Attachments

  • EtherLan SC Installer.image.zip
    234.8 KB · Views: 3
Last edited:

saybur

Well-known member
The Nuvolink uses a 12VAC 2A transformer. However, it looks like Focus did some work on the internals and I can't say for sure if the setup is 1:1 on the hardware side. Here's the Nuvolink for reference.

nuvo.jpg
 

Iesca

Well-known member
Thank you for the info, @saybur. The design was definitely simplified by Focus at some point! I will stick with the 9VAC and see how it works. If it doesn't, I could always try sourcing a new power adapter with a higher amperage rating than my current one, to see if the EtherLan needs more current.
 
Top